ACM需要注意的输入输出格式问题

A+B for Input-Output Practice (VII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84105    Accepted Submission(s): 55767


Problem Description
Your task is to Calculate a + b.
 

Input
The input will consist of a series of pairs of integers a and b, separated by a space, one pair of integers per line. 
 

Output
For each pair of input integers a and b you should output the sum of a and b, and followed by a blank line. 
 

Sample Input
 
 
1 5 10 20
 

Sample Output
 
 
6 30
 

Author
lcy
 


#include<iostream>
using namespace std;
int main(){
	int a, b;
	while(cin >> a >> b){
		cout << a + b << endl << endl;
	}
	return 0;
}


A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 185663    Accepted Submission(s): 55549


Problem Description
Your task is to calculate the sum of some integers.
 

Input
Input contains an integer N in the first line, and then N lines follow. Each line starts with a integer M, and then M integers follow in the same line. 
 

Output
For each group of input integers you should output their sum in one line, and you must note that there is a blank line between outputs.
 

Sample Input
 
 
3 4 1 2 3 4 5 1 2 3 4 5 3 1 2 3
 

Sample Output
 
 
10 15 6
 

Author
lcy

#include<iostream>
using namespace std;
int main(){
	int n;
	cin >> n;
	for(int i = 0; i < n; i++){
		int m, num, ans = 0;
		cin >> m;
		for(int j = 0; j < m; j++){
			cin >> num;
			ans += num;
		}
		cout << ans << endl;
		if(i != n - 1)cout << endl;
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值