刚下的标准版Centos7使用yum安装fish,出现 require libstdc++.so.6(GLIBCXX_3.4.21)

网上一堆解释

这里讲下问题原因和解决思路

原因是版本不够,要求的 libstdc++.so.6版本需要6.0.21以上

可以解决的思路:百度搜

CentOS 7 编译安装gcc升级libstdc

 

我的问题的解决使用这篇文章,编译升级gcc后,搜出来 libstdc++.so.6

利用strings命令看版本,达到了要求,就复制到 /usr/lib64 存放动态链接库下

https://www.cnblogs.com/lvpengbo/p/12719535.html

 

 

 

©️2020 CSDN 皮肤主题: 大白 设计师:CSDN官方博客 返回首页