杭电OJ1000 10001 10002题目及答案

1000


Problem Description
Calculate A + B.
 

Input
Each line will contain two integers A and B. Process to end of file.
 

Output
For each case, output A + B in one line.
 

Sample Input

1 1

 

Sample Output

2


本题没有什么重要的考点
我开始一直不AC的原因在于没有while循环以及不知道Scanner类中还有hasNextInt()一系列方法
import java.util.Scanner;


public class Main{

    public static void main(String args[]){
        int a,b;
        Scanner s=new Scanner(System.in);
        while(s.hasNextInt()){
            a=s.nextInt();
            b=s.nextInt();
            System.out.println((a+b));
        }
    }
}

1001

Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
 

Input
The input will consist of a series of integers n, one integer per line.
 

Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.
 

Sample Input

1
100

 

Sample Output

1

5050



这道题考点也不是很多,关键是你在求这道题目的时候是否想到了用求和公式,以及用求和公式(n+1)*n/2时是否考虑到int类型不能用除法
所以要判断奇偶数,在这里采用了根据int类型是32比特的数通过数的左移31位再右移31位来判断如果是偶数移除之后会为0,否则奇数的话
溢出之后再移回来不为0,这样判断奇数偶数比取模要快一点大约块40ms左右
import java.util.Scanner;

public class Main {
       public static void main(String args[]){
            Scanner s=new Scanner(System.in);
            while(s.hasNextInt()){
                int n=s.nextInt();
                if((n<<31)>>31==0){
                    int sum=n/2;
                    sum=sum*(n+1);
                    System.out.println(sum);
                    System.out.println();
                }
                else{
                    int sum=(n+1)/2;
                    sum=sum*n;
                    System.out.println(sum);
                    System.out.println();
                }
            }
        }

}


1002


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input

2
1 2
112233445566778899 998877665544332211

 

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


这道题根据题目要求不可以使用int类型要用大数来实现求和,知识点也就是大数BigInteger类中常用的方法在我的第七届蓝桥杯决赛第一题
中那篇博客有介绍

import java.math.BigInteger;
import java.util.Scanner;

public class Main {

    public static void main(String args[]){
        Scanner s=new Scanner(System.in);
        int T=s.nextInt();
        for(int i=0;i<T;i++){
            BigInteger a=s.nextBigInteger();
            BigInteger b=s.nextBigInteger();
            BigInteger c=a.add(b);
            System.out.println("Case "+(i+1)+":");
            System.out.println(a.toString()+" + "+b.toString()+" = "+c.toString());
            if(i!=T-1)
                  System.out.println();
        }
    }
}



  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值