PAT A1025 PAT Ranking

PAT (Advanced Level) Practice

题目链接.

  • 编程题1025 PAT Ranking (25 分) || 参考《算法笔记》P103~106

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意
有 n 个考场,每个考场有若干数量的考生。现在给出各个考场中考生的准考证号与分数,要求将所有考生按分数从高到低排序,并按顺序输出所有考生的准考证号、排名、考场号 以及 考场内排名。
思路
在结构体 Student 中存放题目要求的信息(准考证号、分数、考场号、考场内排名)。
根据题目要求,需要写一个排序函数 cmp,规则如下:

  1. 当分数不同时,按分数从大到小排序
  2. 否则,按准考证号从小到大排序
    也即写一个类似于下面这段代码的 cmp 函数:
bool cmp (Student a, Student b) {
	if (a.score != b.score)	return a.score > b.score;	//先按分数从高到低排序
	else return strcmp(a.id, b.id) < 0;	//若分数相同,则按准考证号从小到大排序
}

而算法本体则分为下面三个部分:
步骤 1:按考场读入各考生的信息,并对当前读入考场所有的考生进行排序。之后将该考场的所有考生的排名写入他们的结构体中。
步骤二:对所有考生进行排序。
步骤三:按顺序一边计算总排名,一边输出所有考生的信息。
注意点
对同一考场的考生单独排序的方法:定义 int 型变量 num,用来存放当前获取到的考生人数。每读入一个考生的信息,就让 num 自增。这样当读取完一个考场的考生信息(假设该考场有 k 个考生)后,这个考场的考生所对应的数组下标便为区间 [num-k, num)。

小伙伴们可以去写更棒的方法哦
参考代码

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Student {
	char id[15];	//准考证号
	int score;		//分数
	int location_number;	//考场号
	int local_rank;			//考场内排名
}stu[300];
bool cmp (Student a, Student b) {
	if (a.score != b.score)	return a.score > b.score;	//先按分数从高到低排序
	else return strcmp(a.id, b.id) < 0;	//分数相同按准考证号从小到大排序
}
int main(){
	int n, k, num = 0;	//num为总考生数
	scanf("%d", &n);	//n 为考场数
	for (int i = 1; i <= n; i++) {
		scanf("%d", &k);	//该考场内人数
		for (int j = 0; j < k; j++) {
			scanf("%s %d", stu[num].id, &stu[num].score);
			stu[num].location_number = i;	//该考生的考场号为i
			num++;			//总考生数加1
		}
		sort(stu + num -k, stu + num, cmp);	//将该考场的考生排序
		stu[num-k].local_rank = 1;	//该考场第1名的 local_rank 记为1
		for (int j = num - k + 1; j < num; j++) {	//对考场剩余的考生
			if(stu[j].score == stu[j-1].score){		//如果与前一位考生同分
				//local_rank也相同
				stu[j].local_rank = stu[j-1].local_rank;
			} else {
				//local_rank为该考生前的人数
				stu[j].local_rank = j + 1 - (num - k);
			}
		}
	}
	printf("%d\n", num);	//输出总考生数
	sort(stu, stu + num, cmp);	//将所有考生排序
	int r = 1;
	for (int i = 0; i < num; i++) {
		if (i > 0 && stu[i].score != stu[i-1].score) {
			r = i + 1;	//当前考生与上一个考生分数不同时,让r更新为人数+1
		}
		printf("%s ", stu[i].id);
		printf("%d %d %d\n", r, stu[i].location_number, stu[i].local_rank);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值