项目做一半之后,更改JDK为1.8,需要注意的事项。

原创 2018年04月17日 15:17:17

最近项目中,项目已经开发一半,但是老大决定更换JDK环境为1.8之后。遇到了一些坑。忘记哪些东西需要更改的。

1.Tomcat:这个地方需要进行修改。

2.maven的镜像文件,在conf目录下的settings,修改如下。

<profiles>    
	<profile>      
		<id>jdk-1.8</id>      
		<activation>      
			<activeByDefault>true</activeByDefault>      
			<jdk>1.8</jdk>      
		</activation>      
		<properties>      
			<maven.compiler.source>1.8</maven.compiler.source>      
			<maven.compiler.target>1.8</maven.compiler.target>      
			<maven.compiler.compilerVersion>1.8</maven.compiler.compilerVersion>      
		</properties>      
	</profile>     
</profiles> 
3.eclipse的。就只放一张图片了。毕竟要做项目做到一半去改JDK的应该都不是新手了。虽然我也是个新手,哈哈哈。


4.maven打包,如果有用到maven打包的还要修改这个地方,如果你之前所添加的JDK1.7没有移除的话,打包的时候还是用1.7的javaw.exe去执行的。


弄完以上这个5个地方,就可以愉快的maven update,去写代码了。

jdk安装注意事项

之前就安装了jdk,测试是否安装并且配置环境变量正确的时候,只是简单地测试了一句,即:java -version;其他的就没有管,而之后利用的tomcat依附的jre环境是没有问题的,也就一直用到了J...
  • sinat_27714067
  • sinat_27714067
  • 2016-10-14 23:12:53
  • 321

WEB前端开发技巧与注意事项

心知梦圆 博客园首页新随笔联系管理订阅 随笔- 20  文章- 0  评论- 0  web移动端开发技巧与注意事项汇总 ...
  • chenqingyu000
  • chenqingyu000
  • 2016-09-13 16:45:59
  • 792

jdk1.7升级到1.8遇到的问题

最近想学习Jmeter,于是在官网下载了安装包,可是在打开 Jmeter.bat 时,提示jdk版本过低,于是准备升级jdk,但是又怕影响到之前在myeclipse里面的项目,所有没有卸载1.7,而是...
  • u012627598
  • u012627598
  • 2017-06-14 11:13:32
  • 2866

怎么更改maven工程jdk版本(默为1.5,怎么更改jdk版本为1.8)

使用maven 创建工程更改默认jdk版本(1.5)方法: step1: 找到自己项目的pom.xml文件,添加下图黄色区域代码(文末附上的有代码:可以直接复制) step2: 保存一下更...
  • wudinaniya
  • wudinaniya
  • 2017-07-05 10:48:43
  • 1431

产品类研发项目需要注意的几个问题

1、决定研发产品前,做好可行性分析产品研发是个投入高、见效慢的事情。即便产品上市,仍然需要持续的研发投入。企业或组织在决定投入之前,应做好充分的调研分析。调研分析应从外部和内部两方面入手:外部调研目标...
  • zhangyuk
  • zhangyuk
  • 2006-05-08 14:58:00
  • 2375

ecilpse升级jdk1.8遇到若干问题

今天因为项目需求,将本地的jdk升级到1.8,因此需要将ecilpse的jdk升级一下,但在升级的过程中遇到一些问题,记录下来。 1.升级第一步,因为我的ecilpse比较久,因此点击Windows-...
  • yxyxaut
  • yxyxaut
  • 2016-01-13 16:23:30
  • 1320

c# 窗体编程注意事项

c# datagridview 有时不能设置表头的背景颜色等等 是因为没有将enableheadersvisaulstyles设置为false...
  • leo_cuiyiming
  • leo_cuiyiming
  • 2015-10-18 17:58:06
  • 249

jdk从1.7升级到1.8之后启动出错解决

Caused by: java.lang.IllegalStateException: The System Bundle could not be resolved: Another singlet...
  • xiaolu99999
  • xiaolu99999
  • 2015-08-11 10:12:13
  • 3044

JAVA JDK安装注意事项

在JAVA jdk安装的时候,目录名称最好不要有中文,有逗号,有下划线这样容易出错,比如下面几个安装路径容易出错    java目录/jdk1.6_x86/    这种就是容易出错的目录 正确的方...
  • revent
  • revent
  • 2015-06-10 15:34:28
  • 731

JDK1.6到1.8的注意事项

jdk7都终止更新了,而我们还在用jdk6.。。。 ,安全层面是一个问题,同时有更多的小伙伴早就迫不及待的想使用jdk8才支持的新特性,so,升级计划提上议程,但是升级前的功课还是要做的:   ...
  • hugenshen
  • hugenshen
  • 2016-03-04 15:30:29
  • 7790
收藏助手
不良信息举报
您举报文章:项目做一半之后,更改JDK为1.8,需要注意的事项。
举报原因:
原因补充:

(最多只允许输入30个字)