1004. Counting Leaves

1004. Counting Leaves

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input

Each input file contains one test case. Each case starts with a line containing 0 < N < 100, the number of nodes in a tree, and M (< N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] ... ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID's of its children. For the sake of simplicity, let us fix the root ID to be 01.

Output

For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output "0 1" in a line.

Sample Input
2 1
01 1 02
Sample Output
0 1

译文:

一个家族的层级通常用族谱(树)来记录。你的任务便是找出有多少家庭成员没有子嗣。

输入:一行内输入N和M。N介于0和100之间,是树节点的总个数;M小于N,代表有M个非叶子节点。在接下来M行,将会输入类似于

ID K ID[1] ID[2] ... ID[K]

这样的一个结构。ID是由两位数字构成,是某个非叶节点的编号,K是它的孩子节点的个数,K之后的ID[1]等是它的孩子节点的编号。为了便利,将根节点的编号定义为01。

输出:由根节点开始的每一层,打印该层中那些没有孩子节点的节点个数。一一间隔打印,结尾不得有多余空格。比如上述给出的例子中,输入端共两个节点,很轻易可以构造出两层的树结构,根节点有一个孩子节点,所以第1层的个数为0,第二层只有一个节点,它是叶子节点,没有孩子。所以第二层输出1。

代码:

//

//  main.c

//  1004. Counting Leaves

//

//  Created by shayue on 2018/2/8.

//  Copyright © 2018年 shayue. All rights reserved.

// 找出每一层的叶子节点


#include <stdio.h>

int main() {

 int N,M,flag[100]={0},k;  //flag数组表示某一节点有几个孩子,一开始都为0

 int offspring[100][100]; //后代的信息

 scanf("%d %d",&N,&M);

 for(int i=0;i<M;i++){

  int temp;

  scanf("%d %d",&temp,&k);

  flag[temp]=k; //这个节点一共有k个孩子

  for(int j=0;j<k;j++)

  scanf("%d",&offspring[temp][j]);

 }

 int current_num=1,nochild_num=0,front,rear,count,sum;

 int queue[100];

 front=rear=0;

 if(flag[1]!=0){

  queue[rear]=1;

  rear=(rear+1)%100;

  count=0;

  sum=0;

  while(rear!=front){

   int temp=queue[front];

   front=(front+1)%100;

   count++;

   if(flag[temp]!=0){

    nochild_num++;

    sum+=flag[temp];

   }

   if(current_num==count){   //相等表示该换行了

    if(temp==1)

     printf("%d",current_num-nochild_num);

    else

     printf(" %d",current_num-nochild_num);

    current_num=sum;

    nochild_num=0;

    count=0;

    sum=0;

   }

   for(int i=0;i<flag[temp];i++){

    queue[rear]=offspring[temp][i];

    rear=(rear+1)%100;

   }

  }

 }else

  printf("1");

 return0;

}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值