【 golang 版本升级 go1.18. 】docker golang:alpine 容器golang 版本升级到 go1.18. 导致低版本golang代码报错

我猜今天应该很多人出现了
declared but not used

原因:

使用 docker golang 官方镜像打包 golang:alpine
由于 golang:alpine golang版本更新到了 go1.18.1 低于该版本的go 项目代码会爆
申请变量 在子协程中使用。在主协程中没有使用。declared but not used

解决方法:

  1. golang:alpine 降低golang 版本。这种不考虑哦,大家最好更新到最新版本。
    这里就不在赘述了。
  2. 更新项目中的golang版本 (第一次安装的同学可以跳过这步)
  • 首先查看 版本号 我这是 go version go1.16.4 (大家自行查看)

    go version
    
  • 删除golang旧版本 (Ubuntu)

    sudo apt-get remove golang-go
    sudo apt-get remove --auto-remove golang-go
    
  • 关键一步 记得删除旧的go包。比如默认在/usr/local/go
    在这里插入图片描述

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值