POJ2386 Lake Counting【经典深搜】

Description

Due to recent rains, water has pooled in various places in Farmer John’s field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water (‘W’) or dry land (‘.’). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors.

Given a diagram of Farmer John’s field, determine how many ponds he has.
Input

  • Line 1: Two space-separated integers: N and M

  • Lines 2..N+1: M characters per line representing one row of Farmer John’s field. Each character is either ‘W’ or ‘.’. The characters do not have spaces between them.
    Output

  • Line 1: The number of ponds in Farmer John’s field.
    Sample Input

10 12
W……..WW.
.WWW…..WWW
….WW…WW.
………WW.
………W..
..W……W..
.W.W…..WW.
W.W.W…..W.
.W.W……W.
..W…….W.
Sample Output

3
Hint

OUTPUT DETAILS:

There are three ponds: one in the upper left, one in the lower left,and one along the right side.

思路:从任意的W开始,不停地把邻接的部分用’.’代替。1次DFS后语初始的这个W连接的所有W就都被替换成了’.’,因此直到图中不再有W为止,总共进行了多少次的DSF就是答案。八个方向的便利用两个变量取-1 0 1 来表示。
开始cnt测试样例为31 是因为误把W写成M。。。注意细节。

#include<iostream>
#include<cstdio>
using namespace std;
char pool[105][105];
void dfs(int x, int y ); 
int N,M;
int main()
{

    cin>>N>>M;//N行M列
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<M;j++)
        {
            cin>>pool[i][j]; 
        } 
    } 
    int cnt = 0;
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<M;j++)
        {
            if(pool[i][j]=='W')
            {
                dfs(i,j);
                cnt++;
            //  cout<<cnt<<endl;
            }
        }
    }
    cout<<cnt<<endl;
    return 0;
}

void dfs(int x, int y)
{
    pool[x][y]='.';
    for(int a=-1;a<=1;a++)//行变化 
    {
        for(int b=-1;b<=1;b++)//列变化 
        {
            int xa = x+a;
            int ya = y+b;
            if(xa>=0&&xa<N&&ya>=0&&ya<M&&pool[xa][ya]=='W')
            dfs(xa,ya); 
        } 
    }
    return;

}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值