1043. 输出PATest(20)

  1. 输出PATest(20)

给定一个长度不超过10000的、仅由英文字母构成的字符串。请将字符重新调整顺序,按“PATestPATest…”这样的顺序输出,并忽略其它字符。当然,六种字符的个数不一定是一样多的,若某种字符已经输出完,则余下的字符仍按PATest的顺序打印,直到所有字符都被输出。

输入格式:

输入在一行中给出一个长度不超过10000的、仅由英文字母构成的非空字符串。

输出格式:

在一行中按题目要求输出排序后的字符串。题目保证输出非空。

输入样例:
redlesPayBestPATTopTeePHPereatitAPPT
输出样例:
PATestPATestPTetPTePePee

import java.util.ArrayList;
import java.util.List;
import java.util.Scanner;
 
public class Main {
 
	public static void main(String[] args) {
 
		Scanner in = new Scanner(System.in);
		String string = in.nextLine();
		in.close();
 
		List<Character> PList = new ArrayList<>();
		List<Character> AList = new ArrayList<>();
		List<Character> TList = new ArrayList<>();
		List<Character> eList = new ArrayList<>();
		List<Character> sList = new ArrayList<>();
		List<Character> tList = new ArrayList<>();
 
		for (int i = 0; i < string.length(); i++) {
			switch (string.charAt(i)) {
			case 'P':
				PList.add(string.charAt(i));
				break;
			case 'A':
				AList.add(string.charAt(i));
				break;
			case 'T':
				TList.add(string.charAt(i));
				break;
			case 'e':
				eList.add(string.charAt(i));
				break;
			case 's':
				sList.add(string.charAt(i));
				break;
			case 't':
				tList.add(string.charAt(i));
				break;
 
			}
		}
 
		int maxSize = PList.size();
		if (AList.size() > maxSize) {
			maxSize = AList.size();
		}
		if (TList.size() > maxSize) {
			maxSize = TList.size();
		}
		if (eList.size() > maxSize) {
			maxSize = eList.size();
		}
		if (sList.size() > maxSize) {
			maxSize = sList.size();
		}
		if (tList.size() > maxSize) {
			maxSize = tList.size();
		}
		for (int i = 0; i < maxSize; i++) {
 
			if (i < PList.size()) {
				System.out.print(PList.get(i));
			}
			if (i < AList.size()) {
				System.out.print(AList.get(i));
			}
			if (i < TList.size()) {
				System.out.print(TList.get(i));
			}
			if (i < eList.size()) {
				System.out.print(eList.get(i));
			}
			if (i < sList.size()) {
				System.out.print(sList.get(i));
			}
			if (i < tList.size()) {
				System.out.print(tList.get(i));
			}
		}
	}
 
}

这个题相对来说比较简单,意思比较容易懂,方法也比较容易想到,我看了看网上的大部分代码,大多数以C或C++实现,我看了柳婼学姐Java代码,觉得比较好,就顺手借鉴了下,希望她看到了,勿怪。供喜欢Java的朋友参考,学习
顺便贴出C++实现代码

#include<iostream>  
#include<string>  
using namespace std;  
  
int main(){  
    string s;  
    int P=0,A=0,T=0,e=0,s1=0,t=0;   
    cin>>s;  
    for(int i=0 ;i<s.size() ;i++){  
        if(s[i]=='P'){  
            P++;  
        }  
        if(s[i]=='A'){  
            A++;  
        }  
        if(s[i]=='T'){  
            T++;  
        }  
        if(s[i]=='e'){  
            e++;  
        }  
        if(s[i]=='s'){  
            s1++;  
        }  
        if(s[i]=='t'){  
            t++;  
        }  
    }  
      
    while(1){  
        if(P!=0){  
            cout<<"P";  
            P--;  
        }  
        if(A!=0){  
            cout<<"A";  
            A--;  
        }  
        if(T!=0){  
            cout<<"T";  
            T--;  
        }  
        if(e!=0){  
            cout<<"e";  
            e--;  
        }  
        if(s1!=0){  
            cout<<"s";  
            s1--;  
        }  
        if(t!=0){  
            cout<<"t";  
            t--;  
        }  
        if(P==0&&A==0&&T==0&&e==0&&s1==0&&t==0){  
            break;  
        }  
    }  
    cout<<endl;  
    return 0;  
}   

解题思路3:大佬的代码 与萌新的代码

#include <iostream>
using namespace std;
int main() {
  int map[128] = {0}, c;
  while ((c = cin.get()) != EOF) map[c]++;
  while (map['P'] > 0 || map['A'] > 0 || map['T'] > 0 || map['e'] > 0 || map['s'] > 0 || map['t'] > 0) {
    if (map['P']-- > 0) cout << 'P';
    if (map['A']-- > 0) cout << 'A';
    if (map['T']-- > 0) cout << 'T';
    if (map['e']-- > 0) cout << 'e';
    if (map['s']-- > 0) cout << 's';
    if (map['t']-- > 0) cout << 't';
  }
  return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值