给定一个字符串,输出所有长度至少为 22 的回文子串。
回文子串即从左往右输出和从右往左输出结果是一样的字符串,比如:abba,cccdeedccc都是回文字符串。
输入格式
一个字符串,由字母或数字组成。长度 500 以内。
输出格式
输出所有的回文子串,每个子串一行。
子串长度小的优先输出,若长度相等,则出现位置靠左的优先输出。
输出时每行末尾的多余空格,不影响答案正确性
样例输入
123321125775165561
样例输出
33
11
77
55
2332
2112
5775
6556
123321
165561
解题思路
#include<iostream>
#include<cstdlib>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;
string str;
int len;
int check(int x,int y){//检查从x到y是不是回文字符串
int s = x,t = y;
while( s <= t){
if(str[s] != str[t]){
return 0;//如果不相等直接返回
}
s++,t--;//继续比较
}
for(int i = x;i <= y;i++){//输出这几个字符
cout << str[i];
}
cout << endl;
return 0;
}
int main(){
getline(cin,str);//接收字符串
len = str.size();
for(int k = 1;k < len;k++){//控制比较的字符数目,从两个开始比较
for(int i = 0;i <= len-k;i++){//从第一个字符开始 跨过k个字符数
check(i,i + k);
}
}
return 0;
}