初级篇——穷竭搜索——深度优先搜索 poj3009Curling 2.0

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.

在这里插入图片描述
Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), ©).
The stone stops at the square next to the block it hit.
The block disappears.
The stone gets out of the board.
The game ends in failure.
The stone reaches the goal square.
The stone stops there and the game ends in success.
You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.
在这里插入图片描述
Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).

在这里插入图片描述
Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0 vacant square
1 block
2 start position
3 goal position
The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0
Sample Output

1
4
-1
4
10
-1

读题目!!!因为碰到障碍后障碍会消失,那就是典型的回溯法。

#include<iostream>
#include<cstring>
using namespace std;
const int MAX = 25;
int res,sx,sy,m,n,board[MAX][MAX];
int d[4][2] = {{0,-1},{-1,0},{0,1},{1,0}};
void dfs(int curx,int cury,int step){
	++step;//每次递归都是因为上一次停止后,此题不同于百练的那道小游戏,不是按照路径方向计算路径长度的。
	if(step > res)
		return;//路径可以交叉,所以不使用vis数组,直接剪枝。
	else{
		for(int i = 0;i < 4; ++i){
			int nx = curx + d[i][0];
			int ny = cury + d[i][1];
			if(board[nx][ny] == 1 || board[nx][ny] == -1){//第一步不能走向障碍或者出街。
				continue;
			}
			while(!board[nx][ny]){//走到障碍为止
				nx += d[i][0];
				ny += d[i][1];
			}
			if(board[nx][ny] == -1)
				continue;
			if(board[nx][ny] == 3){
				if(step < res)
					res = step;
				continue;
			}
			if(board[nx][ny] == 1){
				board[nx][ny] = 0;//回溯法
				dfs(nx - d[i][0],ny - d[i][1],step);
				board[nx][ny] = 1;
			}
		}
	}
}
int main(){
	int i,j;
	while(cin >> n >> m && n){
		memset(board,-1,sizeof(board));
		for(i = 1;i <= m; ++i){
			for(j = 1;j <= n; ++j){
				cin >> board[i][j];
				if(board[i][j] == 2){
					sx = i;
					sy = j;
					board[i][j] = 0;
				}
			}
		}
		res = 11;
		dfs(sx,sy,0);
		if(res <= 10)
			cout << res << endl;
		else
			cout << -1 << endl;
	}
	return 0;
} 
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值