Waiting in Line(队列Queue)

1014 Waiting in Line (30 分)

Suppose a bank has N windows open for service. There is a yellow line in front of the windows which devides the waiting area into two parts. The rules for the customers to wait in line are:

  • The space inside the yellow line in front of each window is enough to contain a line with M customers. Hence when all the N lines are full, all the customers after (and including) the (NM+1)st one will have to wait in a line behind the yellow line.
  • Each customer will choose the shortest line to wait in when crossing the yellow line. If there are two or more lines with the same length, the customer will always choose the window with the smallest number.
  • Customer​i​​ will take T​i​​ minutes to have his/her transaction processed.
  • The first N customers are assumed to be served at 8:00am.

Now given the processing time of each customer, you are supposed to tell the exact time at which a customer has his/her business done.

For example, suppose that a bank has 2 windows and each window may have 2 custmers waiting inside the yellow line. There are 5 customers waiting with transactions taking 1, 2, 6, 4 and 3 minutes, respectively. At 08:00 in the morning, customer​1​​ is served at window​1​​ while customer​2​​ is served at window​2​​. Customer​3​​ will wait in front of window​1​​ and customer​4​​ will wait in front of window​2​​. Customer​5​​ will wait behind the yellow line.

At 08:01, customer​1​​ is done and customer​5​​ enters the line in front of window​1​​ since that line seems shorter now. Customer​2​​ will leave at 08:02, customer​4​​ at 08:06, customer​3​​ at 08:07, and finally customer​5​​ at 08:10.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers: N (≤20, number of windows), M (≤10, the maximum capacity of each line inside the yellow line), K (≤1000, number of customers), and Q (≤1000, number of customer queries).

The next line contains K positive integers, which are the processing time of the K customers.

The last line contains Q positive integers, which represent the customers who are asking about the time they can have their transactions done. The customers are numbered from 1 to K.

Output Specification:

For each of the Q customers, print in one line the time at which his/her transaction is finished, in the format HH:MM where HH is in [08, 17] and MM is in [00, 59]. Note that since the bank is closed everyday after 17:00, for those customers who cannot be served before 17:00, you must output Sorry instead.

Sample Input:

2 2 7 5
1 2 6 4 3 534 2
3 4 5 6 7

Sample Output:

08:07
08:06
08:10
17:00
Sorry

思路:

1、有几个窗口就建几个队列,然后弄一个时钟记录时间。比较这几个队列的头部元素,看哪个先结束,就把那个出列,然后再有新的元素入这个队列,然后其他队列的头元素的处理时间减去这个数值,时钟增加,出列的那个元素的结束时间就等于当前时钟时间。循环,直到队列全为空。

2、注意几种情况,排队人数小于N*M,即黄线外没有人。

3、用结束时间减去处理时间,如果小于540才有效,大于等于540则sorry

4、一开始我把记录处理时间的矩阵time[ ]直接在处理中就进行了540的判断,这样是不对的,因为处理时间一直在变化,这样减去的结果跟题目要求的不符合。

import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.io.StreamTokenizer;
import java.text.DecimalFormat;
import java.util.ArrayList;

import java.util.LinkedList;
import java.util.Queue;

public class Main {

	static int N; //窗口
	static int M;	//每个队列的长度
	static int K;	//一共有K个人
	static int Q;	//需要查询的人数

	public static void main(String[] args) throws IOException {
		// TODO Auto-generated method stub
		StreamTokenizer in = new StreamTokenizer(new BufferedReader(new InputStreamReader(System.in)));
		in.nextToken();
		N = (int) in.nval;
		in.nextToken();
		M = (int) in.nval;
		in.nextToken();
		K = (int) in.nval;
		in.nextToken();
		Q = (int) in.nval;

		int[] time = new int[K];
		int [] t_time = new int[K];
		int[] query = new int[Q];

		for (int i = 0; i < K; i++) {
			in.nextToken();
			time[i] = (int) in.nval;
			t_time[i] = (int)in.nval;
		}
		for (int i = 0; i < Q; i++) {
			in.nextToken();
			query[i] = (int) in.nval;
		}
		ArrayList<Queue<Integer>> al = new ArrayList<>();	//新建N个队列
		Queue<Integer> qu;
		for (int i = 0; i < N; i++) {
			qu = new LinkedList<>();
			al.add(qu);
		}
		
		for(int i=0;i<K&&i<N*M;i++) {		//给每个队列赋初始值
			int num = i%N;
			al.get(num).add(i);
		}

		int time_ct = 0;		//时钟用来记录时间
		int counter = N * M;		
		while (true) {
			int temp = Integer.MAX_VALUE;
			int flag = -1;
			for (int i = 0; i < N; i++) {			//寻找N个队列头部元素处理时间的最小值
				if (al.get(i).peek() != null) {
					if (time[al.get(i).peek()] < temp) {
						temp = time[al.get(i).peek()];		//记录时间
						flag = i;							//记录下标
					}
				}
			}
			if (flag > -1) {
				time_ct += temp;					//当前时钟增加
				for (int i = 0; i < N; i++) {
					if (i != flag) {
						if (al.get(i).peek() != null)
							time[al.get(i).peek()] -= temp;		//其他头部节点处理时间减少
					} 
					else {
						
							time[al.get(i).peek()] = time_ct;	//目标头部节点结束的时间
					}
				}
				al.get(flag).poll();		//出列
			}
			if (counter < K) {
				al.get(flag).add(counter);
				counter++;
			}
			if (flag == -1)
				break;
		}

		for (int i = 0; i < Q; i++) {			//输出

			int tm = time[query[i] - 1];
			if (tm -t_time[query[i]-1]<540) {
				int hour = tm / 60 + 8;
				int min = tm % 60;
				DecimalFormat df = new DecimalFormat("00");
				String hr = df.format(hour);
				String mi = df.format(min);
				System.out.println(hr + ":" + mi);
			}
			else
				System.out.println("Sorry");
		}

	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值