linear search java_Linear search in Java The number of occurrences

Implement a method to count the number of occurrences of a value in an array of int's.

Sample Input 1:

19 14 17 15 17

17

Sample Output 1:

2

Sample Input 2:

101 120 103 240

150

Sample Output 2:

0

import java.util.Arrays;

import java.util.Scanner;

public class Main {

public static int count(int[] numbers, int value) {

int count = 0;

for (int temp : numbers) {

if (temp == value) {

++count;

}

}

return count;

}

/* Do not change code below */

@SuppressWarnings("Duplicates")

public static void main(String[] args) {

final Scanner scanner = new Scanner(System.in);

final int[] numbers;

final int k;

if (scanner.hasNextInt()) {

numbers = Arrays.stream(scanner.nextLine().split("\\s+"))

.mapToInt(Integer::parseInt)

.toArray();

k = Integer.parseInt(scanner.nextLine());

} else {

numbers = new int[0];

k = 10;

}

System.out.println(count(numbers, k));

}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值