vue2.9.3安装date-picker组件失败后运行报错

如题:

执行如下操作:

    $ npm install vue-md-date-picker --save

npm run dev 后报错如图所示:

                            图一

这着实让我这新人不知所错,看了_log日志也不知道写的什么乱七八糟,只是说这可能不是npm 的问题?网上搜索同样的问题,有些人回答: 端口冲突! 这也太笼统了吧。

我的解决办法: (无奈的办法) 删除依赖(如图所示的文件夹),重新下载。


            图二

       再进行安装 cnpm install vue-date-picker --save

: 多进行几次以后,我发现,只要第一步 npm install vue-date-picker -- save 在安装过程中报错或者出现问题,

之后即便通过 cnpm install vue-date-picker -- save 安装成功,再运行 npm run dev , 仍然会报错,而且就是报图一的错误。所以,这时候最直接的方法就是删除node_modules这个文件夹,重新下载: cnpm install, 最好使用: cnpm install vue-date-picker -- save将组件一次性安装成功, 之后: npm run dev就可以了。

        当然,大神如果能够找到其中具体出错在哪里,请不吝赐教指导指导!反正我就是这么解决的。其它情况没有尝试,但是如果你第一次安装某个模块或者组件失败后,运行就出错了,并且之后你运行第二遍安装成功了,但是运行就是出错不通过,这个时候你可以试试这个方法。哈哈。。。

PS:  有不对的地方还请指正,希望有人能够提供类似的经历以讨论解决办法。



阅读更多

没有更多推荐了,返回首页