rpm安装python_求救:rpm安装的依赖 存在时报错

安装rpm-python-4.4.2.3-18.el5.x86_64.rpm 时说依赖这个库 可是我查看系统依赖的库都有呀 怎么回事

如下:

[root@localhost chtools]# rpm -ivh rpm-python-4.4.2.3-18.el5.x86_64.rpm

error: Failed dependencies:

libelf.so.1()(64bit) is needed by rpm-python-4.4.2.3-18.el5.x86_64

librpm-4.4.so()(64bit) is needed by rpm-python-4.4.2.3-18.el5.x86_64

librpmbuild-4.4.so()(64bit) is needed by rpm-python-4.4.2.3-18.el5.x86_64

librpmdb-4.4.so()(64bit) is needed by rpm-python-4.4.2.3-18.el5.x86_64

librpmio-4.4.so()(64bit) is needed by rpm-python-4.4.2.3-18.el5.x86_64

popt = 1.10.2.3-18.el5 is needed by rpm-python-4.4.2.3-18.el5.x86_64

rpm = 4.4.2.3-18.el5 is needed by rpm-python-4.4.2.3-18.el5.x86_64

rpm-libs = 4.4.2.3-18.el5 is needed by rpm-python-4.4.2.3-18.el5.x86_64

[root@localhost chtools]# find / -name libelf.so

[root@localhost chtools]# find / -name libelf.so*

/usr/lib64/libelf.so.1

谢谢大家!

|

你是啥系统?

直接yum install rpm-python啊

错误后面的那些要求的版本 和你系统已经安装的版本一致吗

执行下面2个命令 再安装试试

echo "/usr/lib64" >> /etc/ld.so.conf

ldconfig

|

加--force强制安装试试

|

按楼主的描述,那些库都已经有了,可以试试添加--nodeps选项。这个选项不会检查依赖关系。

不过不敢保证一定就成功。

|

up

  • 0
    点赞
  • 0
    收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
©️2022 CSDN 皮肤主题:深蓝海洋 设计师:CSDN官方博客 返回首页
评论
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值