Fibonacci POJ - 3070矩阵乘法+快速幂(水题!!!)

Fibonacci
Time Limit: 1000MS      
Memory Limit: 65536K
Accepted: 12070

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn − 1 + Fn − 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.这里写图片描述

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number −1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.这里写图片描述

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

这里写图片描述

ac代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>
#include<vector>
#include<queue>
#include<stack>
#define ll long long

using namespace std;

const int mod = 10000;
ll n;


struct Matrix{
    ll m[2][2];
} ans, base;


struct Matrix mult(struct Matrix a, struct Matrix b) {
    struct Matrix c;
    for(int i = 0; i < 2; i++)
        for(int j = 0; j < 2; j++)
        {
            c.m[i][j]=0;
            for(int k = 0; k < 2; k++)
                c.m[i][j] += (a.m[i][k]*b.m[k][j])%mod;
                c.m[i][j] %= mod;
        }
    return c;
}
void powl(ll n)
{
    base.m[0][0] =1;
    base.m[0][1] = 1;
    base.m[1][0] = 1;
    base.m[1][1] = 0;
    ans.m[0][0] = ans.m[1][1] = 1; // ans 初始化为单位矩阵
    ans.m[0][1] = ans.m[1][0] = 0;
    while(n)
    {
        if(n&1)   ans = mult(ans,base);
        base = mult(base,base);
        n >>= 1;
    }
}


int main()
{
    scanf("%lld",&n);
    while(n!=-1)
    {
        powl(n);
        printf("%d\n",ans.m[0][1]%mod);
        scanf("%lld",&n);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值