Smith Numbers POJ - 1142(质因数分解)

Smith Numbers
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 14060 Accepted: 4799

Description
While skimming his phone directory in 1982, Albert Wilansky, a mathematician of Lehigh University,noticed that the telephone number of his brother-in-law H. Smith had the following peculiar property: The sum of the digits of that number was equal to the sum of the digits of the prime factors of that number. Got it? Smith’s telephone number was 493-7775. This number can be written as the product of its prime factors in the following way:
4937775= 3*5*5*65837

The sum of all digits of the telephone number is 4+9+3+7+7+7+5= 42,and the sum of the digits of its prime factors is equally 3+5+5+6+5+8+3+7=42. Wilansky was so amazed by his discovery that he named this kind of numbers after his brother-in-law: Smith numbers.
As this observation is also true for every prime number, Wilansky decided later that a (simple and unsophisticated) prime number is not worth being a Smith number, so he excluded them from the definition.
Wilansky published an article about Smith numbers in the Two Year College Mathematics Journal and was able to present a whole collection of different Smith numbers: For example, 9985 is a Smith number and so is 6036. However,Wilansky was not able to find a Smith number that was larger than the telephone number of his brother-in-law. It is your task to find Smith numbers that are larger than 4937775!

Input
The input file consists of a sequence of positive integers, one integer per line. Each integer will have at most 8 digits. The input is terminated by a line containing the number 0.

Output
For every number n > 0 in the input, you are to compute the smallest Smith number which is larger than n,and print it on a line by itself. You can assume that such a number exists.

Sample Input

4937774
0

Sample Output

4937775

题目大意:
要你找一个大于n的和数,并且满足他的各位的和与他所有的质因子的各位的和相等的最小的一个数,即此题的Smith Number
例如对于4937774,比他大的第一个数是4937775

因为4+9+3+7+7+7+5=42

又4937775=3*5*5*65837

而3+5+5+6+5+8+3+7=42

故4937775是题目要求的答案。

这是一道纯数学题,可以通过暴力直接得到答案,因为这样的数分布比较密。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<algorithm>

using namespace std;

int getDigitSum(int a)
{
    int res = 0;
    while(a != 0)
    {
        res += a % 10;
        a /= 10;
    }
    return res;
}

bool factor(int n, int a[], int b[], int &tot) {
    int temp,i,now;
    //temp =  (int)(sqrt((double)n)+1.0);
    tot = 0;
    now = n;
    for(i = 2; i*i <= n; i++) if(now%i == 0) {
        a[++tot] = i;
        b[tot] = 0;
        while(now%i == 0){
            ++b[tot];
            now /= i;
        }
    }
    if(now!=1){
        if(now == n) return false;
        a[++tot] = now;
        b[tot] = 1;
    }
    int s = 0;
    for(int i = 1; i <= tot; i++)
        s += (getDigitSum(a[i])*b[i]);
            //cout << n << " " << getDigitSum(n) << " " << s << endl;
        if(getDigitSum(n) == s) return true;
        else return false;
}



int main()
{
    int n;
    int tot,a[1000],b[1000];
    scanf("%d",&n);
    while(n)
    {
        while(1)
        {
            n++;
            tot = 0;
            if(factor(n,a,b,tot))
            {
                cout << n << endl;
                break;
            }

        }
        scanf("%d",&n);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值