猜数字游戏的提示( Master-Mind Hints UVA - 340)

MasterMind is a game for two players. One of them, Designer, selects a secret code. The other, Breaker,tries to break it. A code is no more than a row of colored dots. At the beginning of a game, the players agree upon the length N that a code must have and upon the colors that may occur in a code.In order to break the code, Breaker makes a number of guesses, each guess itself being a code. After each guess Designer gives a hint, stating to what extent the guess matches his secret code. In this problem you will be given a secret code s1 : : : sn and a guess g1 : : : gn, and are to determine 
the hint. A hint consists of a pair of numbers determined as follows.
A match is a pair (i; j), 1 ≤ i ≤ n and 1 ≤ j ≤ n, such that si = gj. Match (i; j) is called strong when i = j, and is called weak otherwise. Two matches (i; j) and (p; q) are called independent when i = p if and only if j = q. A set of matches is called independent when all of its members are pairwise independent. Designer chooses an independent set M of matches for which the total number of matches and the number of strong matches are both maximal. The hint then consists of the number of strong followed by the number of weak matches in M. Note that these numbers are uniquely determined by the secret code and the guess. If the hint turns out to be (n; 0), then the guess is identical to the secret code.

Input

The input will consist of data for a number of games. The input for each game begins with an integer specifying N (the length of the code). Following these will be the secret code, represented as N integers, which we will limit to the range 1 to 9. There will then follow an arbitrary number of guesses, each also represented as N integers, each in the range 1 to 9. Following the last guess in each game will be N zeroes; these zeroes are not to be considered as a guess. Following the data for the frst game will appear data for the second game (if any) beginning with a new value for N. The last game in the input will be followed by a single ‘0’ (when a value for N would normally be specifed). The maximum value for N will be 1000.

Output

The output for each game should list the hints that would be generated for each guess, in order, one hint per line. Each hint should be represented as a pair of integers enclosed in parentheses and separated by a comma. The entire list of hints for each game should be prefxed by a heading indicating the game number; games are numbered sequentially starting with 1. Look at the samples below for the exact format.

Sample Input
4
1 3 5 5
1 1 2 3
4 3 3 5
6 5 5 1
6 1 3 5
1 3 5 5
0 0 0 0
10
1 2 2 2 4 5 6 6 6 9
1 2 3 4 5 6 7 8 9 1
1 1 2 2 3 3 4 4 5 5
1 2 1 3 1 5 1 6 1 9
1 2 2 5 5 5 6 6 6 7
0 0 0 0 0 0 0 0 0 0
0
Sample Output
Game 1:
(1,1)
(2,0)
(1,2)
(1,2)
(4,0)
Game 2:
(2,4)
(3,2)
(5,0)
(7,0)

题目意思是这样的,给出两个序列A、B,对于A[i]==B[j],如果i==j,那么这是一个strong对,否则这是一个weak对。题目要求先找出所有的strong对,然后找出weak对(一对数字只能用一次)。

思路:
直接统计可得A,为了求B,对每个数字(1~9),统计二者出现的次数c1,c2,则min(c1,c2) - A就是B;

解题代码:

#include<iostream>
#include<string>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<queue>
#include<stack>
#include<map>
#include<iomanip>

using namespace std;

const int maxn = 1e5+7;


int a[maxn],c[maxn];


int main()
{
    int n,caset = 0;
    while(1){
     scanf("%d",&n);
     if(n == 0) break;

     for(int i = 0; i < n; i++) {
            scanf("%d",&a[i]);
            c[i] = a[i];
     }
        printf("Game %d:\n",++caset);
     while(1){
        int sum = 0;
        int sa = 0,sb = 0;
        for(int i = 0; i < n; i++) {
            scanf("%d",&c[i]);
            sum += c[i];
            if(c[i] == a[i])  sa ++;
        }
        if(sum == 0) break;
        for(int d = 1; d <= 9; d++){
                int c1 = 0, c2 = 0;
                for(int i = 0; i < n; i++){
                if(a[i] == d) c1++;
                if(c[i] == d) c2++;
                }
                sb += min(c1,c2);
        }
        printf("    (%d,%d)\n",sa,sb-sa);
     }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值