第六届“浪潮杯”山东省ACM C Game!

Game!

Time Limit: 1000 ms  Memory Limit: 65536 KiB
Problem Description

One day, zbybr is playing a game with blankcqk, here are the rules of the game:

There is a circle of N stones, zbybr and blankcqk take turns taking the stones.

Each time, one player can choose to take one stone or take two adjacent stones.

You should notice that if there are 4 stones, and zbybr takes the 2nd, the 1st and 3rd stones are still not adjacent.

The winner is the one who takes the last stone.

Now, the game begins and zbybr moves first.

 

If both of them will play with the best strategy, can you tell me who will win the game?

Input

The first line of input contains an integer T, indicating the number of test cases (T≈100000).

For each case, there is a positive integer N (N ≤ 10^18).

Output

Output the name of the winner.

Sample Input
2
1
2
Sample Output
zbybr
zbybr
Hint
Source
“浪潮杯”山东省第六届ACM大学生程序设计竞赛

题意:题目很简单,就是给n个石子围成的环,两个人轮流操作。一次只能取一个,或者相邻的两个,问谁能赢。。。

思路:很明显,n>=2时,先手一步就把环给断开了,那么就只能后手赢了,先手只能是可怜的取1-2个这样子的。。。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#define ll long long
using namespace std;
int t;
ll n;


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%lld",&n);
        if(n > 2) puts("blankcqk");
        else puts("zbybr");
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值