北邮oj题库刷题计划(更新ing)

83. A + B Problem

Calculate the sum of two given integers A and B.

输入格式
The input consists of a line with A and B. (−104≤A,B≤104).

输出格式
Output the only answer.

输入样例
2 3
输出样例
5

#include "stdio.h"
 
int main(){
   
    int a,b = 0;
    scanf("%d %d", &a,&b);
    int c = a+b;
    printf("%d",c);
    return 0;
}

84 Single Number

Given an array with N integers where all elements appear three times except for one. Find out the one which appears only once.

输入格式
Several test cases are given, terminated by EOF.

Each test case consists of two lines. The first line gives the length of array N(1≤N≤105), and the other line describes the N elements. All elements are ranged in [0,263−1].

输出格式
Output the answer for each test case, one per line.

输入样例
4
1 1 1 3
10
1 2 3 1 2 3 1 2 3 4
输出样例
3
4

#include <bits/stdc++.h>
using namespace std;
map<unsigned long long int,int> input;	//一定注意范围! WA了好多遍 

int main(){
   
	int n;
	while(scanf("%d",&n)!=EOF){
   
		input.clear();
		unsigned long long int a[n];
		for(int i=0;i<n;i++){
   
			scanf("%llu",&a[i]);
			if(input.find(a[i])==input.end()) input[a[i]]=1;
			else input[a[i]]++;
		}
		for(int i=0;i<n;i++){
   
			if(input[a[i]]==1)
			{
   
				printf("%llu\n",a[i]);
				break;
			}
		}

		
	}
	return 0;
} 

85. Three Points On A Line

题目描述
Given points on a 2D plane, judge whether there’re three points that locate on the same line.

输入格式
The number of test cases T(1≤T≤10) appears in the first line of input.

Each test case begins with the number of points N(1≤N≤100). The following N lines describe the coordinates (xi,yi) of each point, in accuracy of at most 3 decimals. Coordinates are ranged in [−104,104].

输出格式
For each test case, output Yes if there’re three points located on the same line, otherwise output No.

//怎么说呢,我真是菜鸡,一开始以为是精度的问题...但实际上去掉eps也是对的...我疯了,还有要注意斜率为0的,要用乘的形式...
#include<bits/stdc++.h>
#define MAXN 105

int main()
{
   
	int T, i, j, k, m, n, flag;
	double a[MAXN], b[MAXN];
    scanf("%d",&T);
    while(T--){
   
        flag=0;
        scanf("%d",&n);
        scanf("%lf %lf",&a[0],&b[0]);
        scanf("%lf %lf",&a[1],&b[1]);
        for(int m=2;m<n;m++){
   
            scanf("%lf %lf",&a[m],&b[m]);
            for(i=0;i<m-1&&!flag;i++) 
				for(int j=i+1;j<m;j++)
                if(fabs(a[i]*b[j]-a[j]*b[i]+a[j]*b[m]-a[m]*b[j]+a[m]*b[i]-a[i]*b[m])<=1e-6) flag=1;
        }
        if(flag) printf("Yes\n");</
  • 4
    点赞
  • 23
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 回答1: 一本通 OJ 题库的测试数据,通常是用来验证提交的代码在各种情况下的正确性。测试数据可以分为两种类型,手动和自动。 手动测试数据是由题目的出题人根据题意和数据范围设计的一组数据,用来检测程序的正确性和运行效率。手动测试数据的优点是能够涵盖各种情况,但缺点是数量相对较少,不足以覆盖所有可能的情况。 自动测试数据是由程序自动生成的一组数据,可以生成大量的数据以检测程序的健壮性和效率。自动测试数据的优点是数量大且可以自动生成,但缺点是可能无法覆盖某些特殊情况,导致漏洞。 对于提交的代码,一本通 OJ 题库会对其进行编译和运行,然后与测试数据进行比较,判断代码的正确性和效率。如果代码通过了测试数据,就会被判定为正确,否则会被判定为错误,并给出具体的错误信息,供用户进行调试和改进。 综上所述,一本通 OJ 题库的测试数据是一个重要的组成部分,它可以帮助用户测试代码的正确性和运行效率,提高用户的编程技能,同时也可以帮助出题人设计更好的题目,并保证题目的质量和难度。 ### 回答2: 一本通 oj题库是一个在线的程序设计竞赛平台,提供了丰富的编程题目和测试数据。测试数据是用于对程序进行测评的输入和输出数据集合。在题目描述中,会对问题进行详细的解释和要求,并提供多组测试数据作为样例,让程序员运行他们的代码,并得到程序的输出结果。 测试数据通常包括正向测试数据和反向测试数据。正向测试数据是指符合题目条件的测试数据,覆盖了大多数情况,测试程序是否正确;而反向测试数据则是用于测试程序是否能够正确处理异常情况。 在使用一本通 oj题库时,程序员不仅需要通过编写算法和程序的方式解决问题,还需要通过分析测试数据来判断自己的代码是否正确。而一本通 oj题库的丰富数据集合为程序员提供了充足的测试数据,帮助程序员准确地检测代码中存在的漏洞和错误。 总之,一本通 oj题库提供了全面的测试数据来测试程序员的代码是否满足题目描述和要求,是程序员进行程序设计竞赛、算法练习和编程学习的良好平台。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值