数据结构 树 例题 Complete Binary Search Tree

7 篇文章 0 订阅
3 篇文章 0 订阅

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0
Sample Output:

6 3 8 1 5 7 9 0 2 4

#include <stdio.h>
#include <stdlib.h>
#include <math.h>

int compare(const void* a, const void* b);
void Solve(int A[], int T[], int ALeft, int ARight, int TRoot);
int GetLeftLength(int n);

int main()
{
    int N, IsLegal = 0;//N为结点总数
    int* A, *T;//采用两个动态数组,分别指向按从小到大排放的数组和按层序遍历排放数组
    int i;

    QQ: ;
    IsLegal = scanf("%d", &N);
    if(N < 0 || N > 1000 || IsLegal != 1){
        printf("N 输入不合法\t请重新输入\n");
        goto QQ;
    }
    T = (int*)malloc(N * sizeof(int));
    A = (int*)malloc(N * sizeof(int));
    if(A == NULL){
        printf("数组A动态申请内存不成功\n");
        exit(1);
    }else if(T == NULL){
        printf("数组T动态申请内存不成功\n");
        exit(1);
    }
    for(i = 0; i < N; i++){
        scanf("%d", &A[i]);
    }
    qsort(A, N, sizeof(int), compare);//调用库函数进行从小到大的排序
    Solve(A, T, 0, N - 1, 0);
    for(i = 0; i < N - 1; i++){
        printf("%d ", T[i]);
    }
    printf("%d\n", T[N - 1]);
    free(A);
    free(T);
    return 0;
}

int compare(const void* a, const void* b)
{
    return *(int*)a - *(int*)b;
}

void Solve(int A[], int T[], int ALeft, int ARight, int TRoot)
{//遍历数组T,插入元素,使之按层序的顺序放置
    int n, L, LeftRoot, RightRoot;
    n = ARight - ALeft + 1;
    if(n == 0) return;//终止条件是该子树无结点
    L = GetLeftLength(n);//计算n个结点的树,它左子树有多少个结点
    T[TRoot] = A[ALeft + L];//根据左子树的结点个数算出根节点下标,把根节点值放到数组T的根节点位置
    LeftRoot = TRoot * 2 + 1;//对于左子树下一次要放在T的什么位置
    RightRoot = LeftRoot + 1;//对于右子树下一次要放在T的什么位置
    Solve(A, T, ALeft, ALeft + L -1, LeftRoot);
    Solve(A, T, ALeft + L + 1, ARight, RightRoot);
}

int GetLeftLength(int n)
{
    int H, x1, x2, x, L;

    H = floor((log10(n + 1)) / log10(2));
    x1 = n + 1 - pow(2, H);
    x2 = pow(2, H - 1);
    if(x1 < x2){
        x = x1;
    }else{
        x = x2;
    }
    L = x2 - 1 + x;
    return L;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值