【数据结构机试复习11】 soj-1021.Couples 栈

http://soj.acmm.club/1021

1021. Couples

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

N couples are standing in a circle, numbered consecutively clockwise from 1 to 2N. Husband and wife do not always stand together. We remove the couples who stand together until the circle is empty or we can't remove a couple any more.

Can we remove all the couples out of the circle?

Input

There may be several test cases in the input file. In each case, the first line is an integer N(1 <= N <= 100000)----the number of couples. In the following N lines, each line contains two integers ---- the numbers of each couple.
N = 0 indicates the end of the input.

Output

Output "Yes" if we can remove all the couples out of the circle. Otherwise, output "No".

Sample Input

4
1 4
2 3
5 6
7 8

2
1 3
2 4

0

Sample Output

Yes
No


题目大意:

有n对夫妇,每对夫妇的编号如输入的n行所示,所有人按照编号1~2n的顺序站成一个圆圈;

如果一对夫妇站在一起,则把他们从圆圈处剔除;

问最后能否把所有人剔除。


#include <bits/stdc++.h>
using namespace std;
int main() {
	int n;
	while (cin >> n && n) {
		int x, y,couple[200050];
		for (int i = 0; i < n; i++) {
			cin >> x >> y;
			couple[x] = y;
			couple[y] = x;
		}
		stack<int> s;
		for (int i = 1; i <= 2 * n; i++) {
			if (s.empty()) s.push(i);
			else if (couple[i] == s.top()) s.pop();
			else s.push(i);
		}
		if (s.empty()) cout << "Yes\n";
		else cout << "No\n";
	}
	return 0;
}




思路:定义数组couple,存储每对夫妇编号的对应关系;用栈依次处理编号1~2n;

如果栈为空,入栈;

如果栈顶元素和下一元素是夫妇关系,栈顶元素出栈;否则,入栈;

最后看栈是否为空即可。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值