poj3565-Ants

poj3565-Ants

Ants
Time Limit: 5000MS
Memory Limit: 65536K
Special Judge
Description
Young naturalist Bill studies ants in school. His ants feed on plant-louses that live on apple trees. Each ant colony needs its own apple tree to feed itself.
Bill has a map with coordinates of n ant colonies and n apple trees. He knows that ants travel from their colony to their feeding places and back using chemically tagged routes. The routes cannot intersect each other or ants will get confused and get to the wrong colony or tree, thus spurring a war between colonies.
Bill would like to connect each ant colony to a single apple tree so that all n routes are non-intersecting straight lines. In this problem such connection is always possible. Your task is to write a program that finds such connection.
On this picture ant colonies are denoted by empty circles and apple trees are denoted by filled circles. One possible connection is denoted by lines.
Input
The first line of the input file contains a single integer number n (1 ≤ n ≤ 100) — the number of ant colonies and apple trees. It is followed by n lines describing n ant colonies, followed by n lines describing n apple trees. Each ant colony and apple tree is described by a pair of integer coordinates x and y (−10 000 ≤ x, y ≤ 10 000) on a Cartesian plane. All ant colonies and apple trees occupy distinct points on a plane. No three points are on the same line.
Output
Write to the output file n lines with one integer number on each line. The number written on i-th line denotes the number (from 1 to n) of the apple tree that is connected to the i-th ant colony.
Sample Input
5
-42 58
44 86
7 28
99 34
-13 -59
-47 -44
86 74
68 -75
-68 60
99 -60
Sample Output
4
2
1
5
3
Source
Northeastern Europe 2007

考虑abcd是平面上任意四个点,无妨设ab为ant,cd为apple,由三角形法则,连线交叉时比不交叉时短。题目中说明存在一个合法的匹配,对所有匹配状态中任意一个状态,若存在四个点两两连线交叉的点对,则修改为两两不相交,总距离变短,此操作使总距离严格单调减。又存在最终状态使得两两连线不相交,此操作有界。故次操作收敛。所以此题要求完全图的最小权匹配。只需将边权取负,跑一遍最大权匹配即可。

最大权匹配

double U[MAXN], V[MAXN], slack[MAXN], w[MAXN][MAXN];
int n, R[MAXN], L[MAXN];
bool tipU[MAXN], tipV[MAXN];

bool find(int u) {
    tipU[u] = 1;
    for (int i = 1; i <= n; ++i) {
      if (tipV[i]) continue;
      double temp = U[u] + V[i] - w[u][i];
      if (temp <= esp) {
        tipV[i] = 1;
        if (!R[i] || find(R[i])) {
          R[i] = u;
          L[u] = i;
          return true;
        }
      }
      else if (temp < slack[i])
        slack[i] = temp;
    }
    return false;
}

void KM(){
    for (int i = 1; i <= n; ++i) {
      U[i] = -INF, V[i] = R[i] = L[i] = 0;
      for (int j = 1; j <= n; ++j)
        if (U[i] < w[i][j])
          U[i] = w[i][j];
    }
    for (int i = 1; i <= n; ++i) {
      for (int j = 1; j <= n; ++j)
        slack[j] = INF;
      while (true) {
        memset(tipU, 0, sizeof tipU);
        memset(tipV, 0, sizeof tipV);
        if (find(i)) break;
        double d = INF;
        for (int j = 1; j <= n; ++j)
          if (!tipV[j] && d > slack[j])
            d = slack[j];
        for (int j = 1; j <= n; ++j)
          if (tipU[j])
            U[j] -= d;
        for (int j = 1; j <= n; ++j)
          if (tipV[j])
            V[j] += d;
          else
            slack[j] -= d;
      }
    }
    for (int i = 1; i <= n; ++i) 
      printf("%d\n", L[i]);
}

u[],v[]两侧的点标。关于最大权匹配slack松弛值:松弛的是v[]一侧的值。在代码

for (int j = 1; j <= n; ++j)
          if (tipV[j])
            V[j] += d;
          else
            slack[j] -= d;

中,slack[j]-=d是因为slack[i]-=d。
此题代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
using namespace std;
const int MAXN = 110;
const double INF = 1e11;
const double esp = 1e-5;

struct Point{
    double x, y;
}p[MAXN], q[MAXN];

double dis(Point a, Point b){
    return sqrt((a.x-b.x)*(a.x-b.x) + (a.y-b.y)*(a.y-b.y));
}

double U[MAXN], V[MAXN], slack[MAXN], w[MAXN][MAXN];
int n, R[MAXN], L[MAXN];
bool tipU[MAXN], tipV[MAXN];

bool find(int u) {
    tipU[u] = 1;
    for (int i = 1; i <= n; ++i) {
      if (tipV[i]) continue;
      double temp = U[u] + V[i] - w[u][i];
      if (temp <= esp) {
        tipV[i] = 1;
        if (!R[i] || find(R[i])) {
          R[i] = u;
          L[u] = i;
          return true;
        }
      }
      else if (temp < slack[i])
        slack[i] = temp;
    }
    return false;
}

void KM(){
    for (int i = 1; i <= n; ++i) {
      U[i] = -INF, V[i] = R[i] = L[i] = 0;
      for (int j = 1; j <= n; ++j)
        if (U[i] < w[i][j])
          U[i] = w[i][j];
    }
    for (int i = 1; i <= n; ++i) {
      for (int j = 1; j <= n; ++j)
        slack[j] = INF;
      while (true) {
        memset(tipU, 0, sizeof tipU);
        memset(tipV, 0, sizeof tipV);
        if (find(i)) break;
        double d = INF;
        for (int j = 1; j <= n; ++j)
          if (!tipV[j] && d > slack[j])
            d = slack[j];
        for (int j = 1; j <= n; ++j)
          if (tipU[j])
            U[j] -= d;
        for (int j = 1; j <= n; ++j)
          if (tipV[j])
            V[j] += d;
          else
            slack[j] -= d;
      }
    }
    for (int i = 1; i <= n; ++i) 
      printf("%d\n", L[i]);
}

int main()
{
    while(scanf("%d", &n) != EOF) {
      for (int i = 1; i <= n; ++i)
        scanf("%lf%lf", &p[i].x, &p[i].y);
      for (int i = 1; i <= n; ++i)
        scanf("%lf%lf", &q[i].x, &q[i].y);
      for (int i = 1; i <= n; ++i)
        for (int j = 1; j <= n; ++j)
          w[i][j] = -dis(p[i], q[j]);
      KM();
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值