1021 Deepest Root

A traveler's map gives the distances between cities along the highways, together with the cost of each highway. Now you are supposed to write a program to help a traveler to decide the shortest path between his/her starting city and the destination. If such a shortest path is not unique, you are supposed to output the one with the minimum cost, which is guaranteed to be unique.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 4 positive integers N, M, S, and D, where N (≤500) is the number of cities (and hence the cities are numbered from 0 to N−1); M is the number of highways; S and D are the starting and the destination cities, respectively. Then M lines follow, each provides the information of a highway, in the format:

City1 City2 Distance Cost

where the numbers are all integers no more than 500, and are separated by a space.

Output Specification:

For each test case, print in one line the cities along the shortest path from the starting point to the destination, followed by the total distance and the total cost of the path. The numbers must be separated by a space and there must be no extra space at the end of output.

Sample Input:

4 5 0 3
0 1 1 20
1 3 2 30
0 3 4 10
0 2 2 20
2 3 1 20

Sample Output:

0 2 3 3 40

解决思路:

属于单源最短路径问题,考虑用迪杰斯特拉算法,考虑到有多个最短路径时,应输出代价(cost)最小的路径,只要在迪杰斯特拉算法中增加保存到各顶点的cost数组,并更新之, cost数组更新的条件是:1.新路径比当前最短路径短;2.新路径和当前路径长度相等,但新路径的cost小于当前路径的cost.

#include<iostream>
#include<vector>
#include<cstring>

#define INT_MAX 100000000

using namespace std;

int main(){
    int n, m, s, d;
    cin >> n >> m >> s >> d;
    vector<vector<int>> vd(n, vector<int>(n, INT_MAX));
    vector<vector<int>> vc(n, vector<int>(n, INT_MAX));
    
    while(m --){
        int x, y, len, cost;
        cin >> x >> y >> len >> cost;
        vd[x][y] = len;
        vd[y][x] = len;
        vc[x][y] = cost;
        vc[y][x] = cost;
    }
    
    vector<int> dist(n, INT_MAX);
    vector<int> visit(n, false);
    vector<int> path(n, -1);
    vector<int> cost(n, INT_MAX);
    visit[s] = true;
    path[s] = -1;
    
    for(int i = 0; i < n; ++ i){
        if(vd[s][i] < INT_MAX){
            path[i] = s;
        }
        dist[i] = vd[s][i];
        cost[i] = vc[s][i];
    }
    
    for(int k = 1; k < n; ++ k){
        int min_ = INT_MAX;
        int index = -1;
        for(int i = 0; i < n; ++ i){
            if(!visit[i]){
                if(dist[i] < min_){
                    min_ = dist[i];
                    index = i;
                }
            }
        }
        visit[index] = true;
        for(int i = 0; i < n; ++ i){
            if(!visit[i]){
                if(dist[index] + vd[index][i] < dist[i] || 
                   (dist[index] + vd[index][i] == dist[i] && 
                    cost[index] + vc[index][i] < cost[i])){
                    dist[i] = dist[index] + vd[index][i];
                    path[i] = index;
                    cost[i] = cost[index] + vc[index][i];
                }
            }
        }
    }
    string ans = "";
    int t = d;
    while(t != -1){
        ans = to_string(t) + " " + ans;
        t = path[t];
    }
    cout << ans << dist[d] << ' ' << cost[d] << endl;
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值