HDU 1009 贪心

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1009
FatMouse’ Trade

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 96673 Accepted Submission(s): 33689

Problem Description
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output
13.333
31.500

题目大意:一共有n个房子,每个房子里有老鼠喜欢吃的javabeans,但是每个房间里的javabeans的价格不一样。老鼠用m元,问m元最多可以买多少javabeans,每个房间里的javabeans可以被分割。直接贪。
AC代码:

#include<bits/stdc++.h>
typedef struct trade_s {
    //注意这里只能是整数
    int javaBean, catFood;
    double normalize;
} trade_t;

static trade_t w[1100];

//用qsort函数必须注意这个函数返回的是int类型,所以这里会返回1和-1
int cmp(const void * x, const void * y) {
    //注意这里直接用减法并且返回1和-1
    return ((trade_t*)x)->normalize - ((trade_t*)y)->normalize > 0 ? -1 : 1;
}

int main() {
    //n是行数,m是总重量
    int n, m, i;
    double sum;

    while (scanf("%d %d", &m, &n)) {
        //输入-1结束
        if (m == -1 && n == -1) break;
        //重置sum
        sum = 0;
        //输入n行数据
        for (i = 0; i <= n - 1; i++) {
            //得到javaBean需要付出catFood
            scanf("%d %d", &w[i].javaBean, &w[i].catFood);
            //计算单价购买量
            w[i].normalize = ((double)w[i].javaBean) / w[i].catFood;
        }
        //排序
        qsort(w, n, sizeof(trade_t), cmp);

        for (i = 0; i < n; i++) {
            //如果支付得起,则购买
            if (m >= w[i].catFood) {
                //printf("food %d %d\n", w[i].catFood, w[i].javaBean);
                //增加获得的重量
                sum = sum + w[i].javaBean;
                //减去付出
                m -= w[i].catFood;
            } else {
                //支付不起,以单价购买量乘以重量
                sum = sum + w[i].normalize * m;
                break;
            }
        }
        printf("%.3lf\n", sum);
        cout<<fixed<<setprication(3)<<sum<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值