【算法练习】动态规划/01背包 百练poj 4131:Charm Bracelet

题目地址:OpenJudge - 4131:Charm Bracelet

4131:Charm Bracelet

总时间限制: 

1000ms

内存限制: 

65536kB

描述

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N(1 ≤ N≤ 3,402) available charms. Each charm iin the supplied list has a weight Wi(1 ≤ Wi≤ 400), a 'desirability' factor Di(1 ≤ Di≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M(1 ≤ M≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

输入

Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

输出

Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

样例输入

4 6
1 4
2 6
3 12
2 7

样例输出

23

题目理解:有一些单词不太认识,但根据一些关键性描述可以看出来这就是一个普通的01背包的问题。

AC代码如下:

#include<iostream>
#include <string.h>
using namespace std;

//01背包问题
//and can be used at most once
int N,M;
int w[4000];   //weight
int v[4000];   // a 'desirability' factor
int dp[13300];   //因为dp数组开始开的不够大
int main(){
    cin>>N>>M;
    for(int i=1;i<=N;i++){
        cin>>w[i]>>v[i];
    }

    memset(dp,0, sizeof(dp));
 //dp[i][j]= max(dp[i-1][j-w[i]]+v[i],dp[i-1][j] ) 前i个里 背包容量为j 总价值最大为dp[i][j]
   //下面的代码是用一维数组优化后的 
   //所以内层循环需要从后往前赋值,因为会用到前面的数值
    dp[0]=0;
    for(int i=1;i<=N;i++){
        for(int j=M;j>=w[i];j--){
            if(dp[j-w[i]]+v[i]>dp[j]){
                dp[j]=dp[j-w[i]]+v[i];
            }
        }
    }

    cout<<dp[M]<<endl;
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值