hdu 4251 The Famous ICPC Team Again(划分树模板)

The Famous ICPC Team Again

Time Limit: 30000/15000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1821    Accepted Submission(s): 854


 

Problem Description

When Mr. B, Mr. G and Mr. M were preparing for the 2012 ACM-ICPC World Final Contest, Mr. B had collected a large set of contest problems for their daily training. When they decided to take training, Mr. B would choose one of them from the problem set. All the problems in the problem set had been sorted by their time of publish. Each time Prof. S, their coach, would tell them to choose one problem published within a particular time interval. That is to say, if problems had been sorted in a line, each time they would choose one of them from a specified segment of the line.

Moreover, when collecting the problems, Mr. B had also known an estimation of each problem’s difficultness. When he was asked to choose a problem, if he chose the easiest one, Mr. G would complain that “Hey, what a trivial problem!”; if he chose the hardest one, Mr. M would grumble that it took too much time to finish it. To address this dilemma, Mr. B decided to take the one with the medium difficulty. Therefore, he needed a way to know the median number in the given interval of the sequence.

 

 

Input

For each test case, the first line contains a single integer n (1 <= n <= 100,000) indicating the total number of problems. The second line contains n integers xi (0 <= xi <= 1,000,000,000), separated by single space, denoting the difficultness of each problem, already sorted by publish time. The next line contains a single integer m (1 <= m <= 100,000), specifying number of queries. Then m lines follow, each line contains a pair of integers, A and B (1 <= A <= B <= n), denoting that Mr. B needed to choose a problem between positions A and B (inclusively, positions are counted from 1). It is guaranteed that the number of items between A and B is odd.

 

 

Output

For each query, output a single line containing an integer that denotes the difficultness of the problem that Mr. B should choose.

 

 

Sample Input

 

5 5 3 2 4 1 3 1 3 2 4 3 5 5 10 6 4 8 2 3 1 3 2 4 3 5

 

 

Sample Output

 

Case 1: 3 3 2 Case 2: 6 6 4

 

 

Source

Fudan Local Programming Contest 2012

 

 

Recommend

We have carefully selected several similar problems for you:  4255 4247 4252 4246 4248 

题目大意:求区间中位数

题解:划分树模板题,求一下区间中间大的就行,题目说区间长度为奇数。

 

#include<bits/stdc++.h>
using namespace std;
#define LL long long
#define N 100005
int t[20][N],tl[20][N];
int sor[N];

void build(int l,int r,int dep)
{
    if(l==r)return ;
    int m=(l+r)>>1;
    int same = m-l+1;
    for(int i=l;i<=r;i++)if(t[dep][i]<sor[m])same--;
    int ln=l;
    int rn=m+1;

    for(int i=l;i<=r;i++)
    {
        if(t[dep][i]<sor[m]||(t[dep][i]==sor[m]&&same>0))
        {
            t[dep+1][ln++]=t[dep][i];
            if(t[dep][i]==sor[m])same--;
            tl[dep][i]=tl[dep][l-1]+ln-l;
        }
        else
        {
            t[dep+1][rn++]=t[dep][i];
            tl[dep][i]=tl[dep][i-1];
        }
    }
    build(l,m,dep+1);
    build(m+1,r,dep+1);
}

int query(int l,int r,int ql,int qr,int k,int dep)
{
    if(l==r)return t[dep][l];
    int m=(l+r)>>1;
    int cnt=tl[dep][qr]-tl[dep][ql-1];
    if(cnt>=k)
    {
        int newl=l+tl[dep][ql-1]-tl[dep][l-1];
        int newr=newl+cnt-1;
        return query(l,m,newl,newr,k,dep+1);
    }
    else
    {
        int newr=qr+tl[dep][r]-tl[dep][qr];
        int newl=newr-(qr-ql-cnt);
        return query(m+1,r,newl,newr,k-cnt,dep+1);
    }
}



int main()
{
    int n;
    int cas=1;
    while(~scanf("%d",&n)){
    for(int i=1;i<=n;i++)
    {
        scanf("%d",&t[0][i]);
        sor[i]=t[0][i];
    }
    sort(sor+1,sor+1+n);
    build(1,n,0);
    int m;
    scanf("%d",&m);
    printf("Case %d:\n",cas++);
    while(m--)
    {
        int l,r;
        scanf("%d%d",&l,&r);
        printf("%d\n",query(1,n,l,r,(r-l)/2+1,0));
    }
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值