ACM-ICPC 2018 焦作赛区网络预赛 Transport Ship (多重背包)

There are NN different kinds of transport ships on the port. The i^{th}ith kind of ship can carry the weight of V[i]V[i] and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1. How many different schemes there are if you want to use these ships to transport cargo with a total weight of SS?

It is required that each ship must be full-filled. Two schemes are considered to be the same if they use the same kinds of ships and the same number for each kind.

Input

The first line contains an integer T(1 \le T \le 20)T(1≤T≤20), which is the number of test cases.

For each test case:

The first line contains two integers: N(1 \le N \le 20), Q(1 \le Q \le 10000)N(1≤N≤20),Q(1≤Q≤10000), representing the number of kinds of ships and the number of queries.

For the next NN lines, each line contains two integers: V[i](1 \le V[i] \le 20), C[i](1 \le C[i] \le 20)V[i](1≤V[i]≤20),C[i](1≤C[i]≤20), representing the weight the i^{th}ith kind of ship can carry, and the number of the i^{th}ith kind of ship is 2^{C[i]} - 12C[i]−1.

For the next QQ lines, each line contains a single integer: S(1 \le S \le 10000)S(1≤S≤10000), representing the queried weight.

Output

For each query, output one line containing a single integer which represents the number of schemes for arranging ships. Since the answer may be very large, output the answer modulo 10000000071000000007.

样例输入复制

1
1 2
2 1
1
2

样例输出复制

0
1

题目来源

ACM-ICPC 2018 焦作赛区网络预赛

 

解题思路:每个船的个数有2的i次方-1个,刚好的分解成i个每个容量为v[i]*2的多少次幂,并且这些数可以组成该数这内所有的数

这也正是能用2进制优化的原因。其余的和求01背包能装满的方案有多少种一样。

#include<iostream>
#include<cstdio>
#include<vector>
#include<cstring>
using namespace std;
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define sca(x) scanf("%d",&x)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define inf 0x3f3f3f3f
#define mod 1000000007
#define LL long long
LL  dp[10005];
LL  a[36],b[30];
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int n,q;
        sca(n),sca(q);
        rep(i,1,n)
        {
            scanf("%lld%lld",a+i,b+i);
        }
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        rep(i,1,n)
        {
           rep(k,0,b[i]-1)
           {
               per(j,10000,a[i]*(1LL<<k))
               {
                    if((1LL<<k)*a[i]<=j)
                    {
                        dp[j]=(dp[j]+dp[j-(1LL<<k)*a[i]])%mod;
                    }
               }
           }
        }
        rep(i,1,q)
        {
            int qq;
            sca(qq);
            printf("%lld\n",dp[qq]);
        }
    }
}
/*
1
4 2
1 1
1 1
2 1
2 1
4
3
*/

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值