hdu 5459 (dp)

Jesus Is Here

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 65535/102400 K (Java/Others)
Total Submission(s): 912    Accepted Submission(s): 661


 

Problem Description

I've sent Fang Fang around 201314 text messages in almost 5 years. Why can't she make sense of what I mean?
``But Jesus is here!" the priest intoned. ``Show me your messages."
Fine, the first message is s1=‘‘c" and the second one is s2=‘‘ff".
The i-th message is si=si−2+si−1 afterwards. Let me give you some examples.
s3=‘‘cff", s4=‘‘ffcff" and s5=‘‘cffffcff".

``I found the i-th message's utterly charming," Jesus said.
``Look at the fifth message". s5=‘‘cffffcff" and two ‘‘cff" appear in it.
The distance between the first ‘‘cff" and the second one we said, is 5.
``You are right, my friend," Jesus said. ``Love is patient, love is kind.
It does not envy, it does not boast, it is not proud. It does not dishonor others, it is not self-seeking, it is not easily angered, it keeps no record of wrongs.
Love does not delight in evil but rejoices with the truth.
It always protects, always trusts, always hopes, always perseveres."

Listen - look at him in the eye. I will find you, and count the sum of distance between each two different ‘‘cff" as substrings of the message.

 

 

Input

An integer T (1≤T≤100), indicating there are T test cases.
Following T lines, each line contain an integer n (3≤n≤201314), as the identifier of message.

 

 

Output

The output contains exactly T lines.
Each line contains an integer equaling to:

∑i<j:sn[i..i+2]=sn[j..j+2]=‘‘cff"(j−i) mod 530600414,


where sn as a string corresponding to the n-th message.

 

 

Sample Input

 

9 5 6 7 8 113 1205 199312 199401 201314

 

 

Sample Output

 

Case #1: 5 Case #2: 16 Case #3: 88 Case #4: 352 Case #5: 318505405 Case #6: 391786781 Case #7: 133875314 Case #8: 83347132 Case #9: 16520782

 

 

Source

2015 ACM/ICPC Asia Regional Shenyang Online

 

 

Recommend

wange2014   |   We have carefully selected several similar problems for you:  6447 6446 6445 6444 6443 

解题思路:求第n个串,所有c字符的位置之差的和。

考虑如何由前两个的ans得到第三个的ans

如上图所示前半段和后半段内部的差值之和我们知道,只需要求后半段和前半段的位置差值之和,公式容易得到

只需要两部分的长度,c字符位置之和和c字符的个数。

#include<iostream>
#include<cstdio>
#include<vector>
#include<queue>
#include<set>
#include<algorithm>
#include<cstring>
using namespace std;
#define rep(i,j,k) for(int i=j;i<=k;i++)
#define sca(x) scanf("%d",&x)
#define per(i,j,k) for(int i=j;i>=k;i--)
#define inf 0x3f3f3f3f
#define LL long long
#define N 10600
#define inf 0x3f3f3f3f
const LL mod = 530600414;

struct node
{
    LL num,pos,ans,len;
}dp[201315];
void init(int n)
{
    dp[3].num=1,dp[3].pos=1,dp[3].ans=0,dp[3].len=3;
    dp[4].num=1,dp[4].pos=3,dp[4].ans=0,dp[4].len=5;
    for(int i=5;i<=n;i++)
    {
        dp[i].len=(dp[i-1].len+dp[i-2].len)%mod;
        dp[i].num=(dp[i-1].num+dp[i-2].num)%mod;
        dp[i].pos=(((dp[i-1].pos+(dp[i-2].len*dp[i-1].num)%mod)%mod)+dp[i-2].pos)%mod;
        dp[i].ans=((((dp[i-1].ans+dp[i-2].ans)%mod+(((dp[i-1].pos+((dp[i-2].len*dp[i-1].num)%mod))%mod)*dp[i-2].num)%mod)%mod
        -(dp[i-2].pos*dp[i-1].num)%mod)+mod)%mod;
    }
}
int main()
{
    int t;
    cin>>t;
    init(201314);
    int cas=0;
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("Case #%d: %lld\n",++cas,dp[n].ans%mod);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值