Monitor

Problem Description

Xiaoteng has a large area of land for growing crops, and the land can be seen as a rectangle of n×m. 

But recently Xiaoteng found that his crops were often stolen by a group of people, so he decided to install some monitors to find all the people and then negotiate with them.

However, Xiao Teng bought bad monitors, each monitor can only monitor the crops inside a rectangle. There are p monitors installed by Xiaoteng, and the rectangle monitored by each monitor is known. 

Xiao Teng guess that the thieves would also steal q times of crops. he also guessed the range they were going to steal, which was also a rectangle. Xiao Teng wants to know if his monitors can see all the thieves at a time.

 

 

Input

There are mutiple test cases.

Each case starts with a line containing two integers n,m(1≤n,1≤m,n×m≤107) which represent the area of the land.

And the secend line contain a integer p(1≤p≤106) which represent the number of the monitor Xiaoteng has installed. This is followed by p lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m) ,meaning the lower left corner and upper right corner of the rectangle.

Next line contain a integer q(1≤q≤106) which represent the number of times that thieves will steal the crops.This is followed by q lines each describing a rectangle. Each of these lines contains four intergers x1,y1,x2 and y2(1≤x1≤x2≤n,1≤y1≤y2≤m),meaning the lower left corner and upper right corner of the rectangle.

 

 

Output

For each case you should print q lines.

Each line containing YES or NO mean the all thieves whether can be seen.

 

 

Sample Input

 

6 6 3 2 2 4 4 3 3 5 6 5 1 6 2 2 3 2 5 4 1 5 6 5

 

 

Sample Output

 

YES NO

Hint

In the picture,the red solid rectangles mean the monitor Xiaoteng installed, and the blue dotted rectangles mean the area will be stolen.

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=6514

#include<bits/stdc++.h>
#define rep(i,a,b) for(int i=a;i<=b;i++)
using namespace std;
const int maxn=20000010;
int N,M,a[maxn];
void add(int i,int j,int val)
{
    if(i>N||j>M) return ;
    a[(i-1)*M+j]+=val;
}
int query(int i,int j)
{
    if(i==0||j==0) return 0;
    return a[(i-1)*M+j];
}
int main()
{
    int P,Q,x1,x2,y1,y2;
    while(~scanf("%d%d",&N,&M))
    {
        for(int i=1;i<=N*M; i++) a[i]=0;
        scanf("%d",&P);
        for(int i=1; i<=P; i++)
        {
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            add(x1,y1,1);
            add(x1,y2+1,-1);
            add(x2+1,y1,-1);
            add(x2+1,y2+1,1);
        }
        //第一次前缀和得到被多少个覆盖
        for(int i=1; i<=N; i++)
            for(int j=1; j<=M; j++)
                a[(i-1)*M+j]=query(i,j-1)+query(i-1,j)-query(i-1,j-1)+a[(i-1)*M+j];
        //处理二次多次覆盖区域
        for(int i=1; i<=N*M; i++)
                if(a[i]!=0)
                    a[i]=1;
        //计算二维前缀和
        for(int i=1; i<=N; i++)
            for(int j=1; j<=M; j++)
                a[(i-1)*M+j]=query(i,j-1)+query(i-1,j)-query(i-1,j-1)+a[(i-1)*M+j];

        scanf("%d",&Q);
        for(int i=1; i<=Q; i++)
        {
            scanf("%d%d%d%d",&x1,&y1,&x2,&y2);
            int res=query(x2,y2)+query(x1-1,y1-1)-query(x1-1,y2)-query(x2,y1-1);
            if(res==(x2-x1+1)*(y2-y1+1)) printf("YES\n");
            else printf("NO\n");
        }
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值