Schrödinger's Knapsack

DreamGrid has a magical knapsack with a size capacity of  called the Schrödinger's knapsack (or S-knapsack for short) and two types of magical items called the Schrödinger's items (or S-items for short). There are  S-items of the first type in total, and they all have a value factor of ; While there are  S-items of the second type in total, and they all have a value factor of . The size of an S-item is given and is certain. For the -th S-item of the first type, we denote its size by ; For the -th S-item of the second type, we denote its size by .

But the value of an S-item remains uncertain until it is put into the S-knapsack (just like Schrödinger's cat whose state is uncertain until one opens the box). Its value is calculated by two factors: its value factor , and the remaining size capacity  of the S-knapsack just after it is put into the S-knapsack. Knowing these two factors, the value  of an S-item can be calculated by the formula .

For a normal knapsack problem, the order to put items into the knapsack does not matter, but this is not true for our Schrödinger's knapsack problem. Consider an S-knapsack with a size capacity of 5, an S-item with a value factor of 1 and a size of 2, and another S-item with a value factor of 2 and a size of 1. If we put the first S-item into the S-knapsack first and then put the second S-item, the total value of the S-items in the S-knapsack is ; But if we put the second S-item into the S-knapsack first, the total value will be changed to . The order does matter in this case!

Given the size of DreamGrid's S-knapsack, the value factor of two types of S-items and the size of each S-item, please help DreamGrid determine a proper subset of S-items and a proper order to put these S-items into the S-knapsack, so that the total value of the S-items in the S-knapsack is maximized.

Input

The first line of the input contains an integer  (about 500), indicating the number of test cases. For each test case:

The first line contains three integers ,  and  (), indicating the value factor of the first type of S-items, the value factor of the second type of S-items, and the size capacity of the S-knapsack.

The second line contains two integers  and  (), indicating the number of the first type of S-items, and the number of the second type of S-items.

The next line contains  integers  (), indicating the size of the S-items of the first type.

The next line contains  integers  (), indicating the size of the S-items of the second type.

It's guaranteed that there are at most 10 test cases with their  larger than 100.

Output

For each test case output one line containing one integer, indicating the maximum possible total value of the S-items in the S-knapsack.

Sample Input

3
3 2 7
2 3
4 3
1 3 2
1 2 10
3 4
2 1 2
3 2 3 1
1 2 5
1 1
2
1

Sample Output

23
45
10

AC代码:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const int maxn=2010;
inline int read()
{
    char ch = getchar();
    int x = 0, f = 1;
    while(ch < '0' || ch > '9')
    {
        if(ch == '-')
            f = -1;
        ch = getchar();
    }
    while('0' <= ch && ch <= '9')
    {
        x = x * 10 + ch - '0';
        ch = getchar();
    }
    return x * f;
}
int a[maxn],b[maxn];
ll sa[maxn],sb[maxn];
ll dp[maxn][maxn];
int main()
{
    int T;
    scanf("%d",&T);
    int n,m,k1,k2,c;
    while(T--)
    {
        dp[0][0]=0;
        sa[0]=0; sb[0]=0;
        scanf("%d %d %d",&k1,&k2,&c);
        scanf("%d %d",&n,&m);
        for(int i=1; i<=n; i++) a[i]=read();
        for(int i=1; i<=m; i++) b[i]=read();
        //排序,根据题意,优先塞体积小的
        sort(a+1,a+n+1);
        sort(b+1,b+m+1);
        //处理前缀和;
        for(int i=1; i<=n; i++) sa[i]=sa[i-1]+a[i];
        for(int i=1; i<=m; i++) sb[i]=sb[i-1]+b[i];
        //计算只拿a队列一个和b队列一个的情况
        dp[1][0]=k1*(c-a[1]);
        dp[0][1]=k2*(c-b[1]);
        //初始化res=0防止题目坑出现负数
        ll  res=0;
        ll  p,q;
        res=max(dp[1][0],dp[0][1]);
        for(int i=0; i<=n; i++)
            for(int j=0; j<=m; j++)
            {
                //dp[i][j]表示选择了a的i个和b的j个
                if(i==0&&j==0) continue;
                if(i==0) p=0;
                else p=dp[i-1][j]+(c-sa[i]-sb[j])*k1;
                if(j==0) q=0;
                else q=dp[i][j-1]+(c-sa[i]-sb[j])*k2;
                dp[i][j]=max(p,q);
                res=max(res,dp[i][j]);
            }
        printf("%lld\n",res);
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值