Sticks(hdu1455,深搜)

      传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1455

Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12642    Accepted Submission(s): 3872


 

Problem Description

George took sticks of the same length and cut them randomly until all parts became at most 50 units long. Now he wants to return sticks to the original state, but he forgot how many sticks he had originally and how long they were originally. Please help him and design a program which computes the smallest possible original length of those sticks. All lengths expressed in units are integers greater than zero.

 

 

Input

The input contains blocks of 2 lines. The first line contains the number of sticks parts after cutting, there are at most 64 sticks. The second line contains the lengths of those parts separated by the space. The last line of the file contains zero.

 

 

Output

The output file contains the smallest possible length of original sticks, one per line.

 

 

Sample Input

 

9 5 2 1 5 2 1 5 2 1 4 1 2 3 4 0

 

 

Sample Output

 

6 5

     这道题目需要许多剪枝,让我体会到剪枝的重要性

#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
using namespace std;

int a[65],vis[65],n,flag,sum,maxd;

void dfs(int x,int d,int num)///x:第几段小木棍,d:当前组合长度,num:用了几段木棍
{
    if(flag) return ;
    if(num==n)///用完所以木棍
    {
        flag=1;
        return ;
    }
    for(int i=0;i<n;i++)
    {
        if(!vis[i]&&d+a[i]<=maxd)
        {
            vis[i]=1;
            if(d+a[i]==maxd)
                dfs(x+1,0,num+1);
            else dfs(x+1,d+a[i],num+1);
            vis[i]=0;
            if(flag) return ;
            if(d==0) return ;            ///最重要的 不写 直接TLE  当递归回来前面长棍子没用到的话 之后也就用不到了
            while(i<n&&a[i]==a[i+1]) i++;///当前长木棍不可以,呢么同样长就跳过
        }
    }
}

int main()
{
    while(scanf("%d",&n)&&n)
    {
        sum=0,flag=0;
        for(int i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        sort(a,a+n,greater<int>());
        for(int i=a[0];i<=sum&&!flag;i++)
        {
            if(sum%i==0)///可以整除才有必要分析
            {
                maxd=i;///合并后的最大长度
                dfs(0,0,0);
                if(flag)
                    printf("%d\n",i);
            }
        }
    }
    return 0;
}

 

  • 1
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值