F(x)
For a decimal number x with n digits (A nA n-1A n-2 ... A 2A 1), we define its weight as F(x) = A n * 2 n-1 + A n-1 * 2 n-2 + ... + A 2 * 2 + A 1 * 1. Now you are given two numbers A and B, please calculate how many numbers are there between 0 and B, inclusive, whose weight is no more than F(A).
Input
The first line has a number T (T <= 10000) , indicating the number of test cases.
For each test case, there are two numbers A and B (0 <= A,B < 10 9)
Output
For every case,you should output "Case #t: " at first, without quotes. The t is the case number starting from 1. Then output the answer.
Sample Input
3
0 100
1 10
5 100
Sample Output
Case #1: 1
Case #2: 2
Case #3: 13
解析:
t组测试数据
每行一个a,b
求1~b中x,f(x)<=f(a)的数目
ac:
#include<bits/stdc++.h>
#define ll long long
#define MAXN 200005
using namespace std;
ll a[12];
ll dp[12][MAXN];
ll f(int x)
{
ll sum=0;
int i=0;
while(x)
{
sum+=(x%10)*pow(2,i);
i++;
x=x/10;
}
return sum;
}
ll dfs(ll pos,ll all,bool limit)
{
if(pos==-1)
{
return all>=0;
}
if(all<0)
return 0;
if(!limit && dp[pos][all] != -1)
return dp[pos][all];
ll up = limit ? a[pos] : 9;
ll ans=0;
for(ll i=0;i <= up;i++)
ans += dfs(pos-1,all-i*(1<<pos),limit && i == a[pos]);
if(!limit)
dp[pos][all]=ans;
return ans;
}
ll solve(ll y,ll x)
{
ll pos=0;
while(x)
{
a[pos++]=x%10;
x/=10;
}
ll all=f(y);
return dfs(pos-1,all,1);
}
int main()
{
ll t,a,b;
scanf("%lld",&t);
memset(dp,-1,sizeof(dp));
int cas=1;
while(t--)
{
scanf("%lld%lld",&a,&b);
printf("Case #%d: %lld\n",cas++,solve(a,b));
}
return 0;
}