线段树

线段树区间求最大值 ;单点修改。

线段树模版:

        时间复杂度O(logn).

        我觉得主要还是递归的思想,和二分思想吧。(递归建树,递归查询,递归修改)

建树:

void BuildTree (int i, int left, int right){
    node[i].left = left;
    node[i].right = right;
    node[i].val = 0;
    if(left == right){
        father[left] = i;
        return ;
    }
    BuildTree (i << 1, left, (int)(floor (left + right)/2.0));
    BuildTree ((i << 1) +1, (int)(floor (left + right)/2.0) + 1, right);
}

单点修改:

    

void UpdateTree (int ri){
    if(ri == 1) return ;
    int fi = ri / 2;
    int a = node[fi << 1].val;
    int b = node[(fi << 1)+1].val;
    node[fi].val = max (a,b);
    UpdateTree (ri/2);
}

区间求最大值:

    

void search (int i, int l, int r){
    if(node[i].left == l && node[i].right == r){
        Max = max (Max, node[i].val);
        return ;
    }
    i = i<<1;
    if(l <= node[i].right){
        if (r <= node[i].right){
            search (i , l ,r);
        }
        else{
            search (i, l, node[i].right);
        }
    }
    i++;
    if(r >= node[i].left){
        if (l >= node[i].left){
            search (i, l ,r);
        }
        else{
            search (i,node[i].left, r);
        }
    }
}

  区间求和:

        

void search (int i , int l , int r){
	if (node[i].left == l && node[i].right == r){
		Max += node[i].val;
		return ;
	}
	i = i << 1;
	if (l <= node[i].right){
		if (l <= node[i].left){
			search (i, l, r);
		}
		else{
			search (i, l, node[i].right);
		}
	}
	i++;
	if (r >= node[i].left){
		if (r >= node[i].right){
			search (i, l ,r);
		}
		else{
			search (i, node[i].left, r);
		}
	}
}

  题目链接:点击打开链接

Problem Description
很多学校流行一种比较的习惯。老师们很喜欢询问,从某某到某某当中,分数最高的是多少。
这让很多学生很反感。

不管你喜不喜欢,现在需要你做的是,就是按照老师的要求,写一个程序,模拟老师的询问。当然,老师有时候需要更新某位同学的成绩。
 

Input
本题目包含多组测试,请处理到文件结束。
在每个测试的第一行,有两个正整数 N 和 M ( 0<N<=200000,0<M<5000 ),分别代表学生的数目和操作的数目。
学生ID编号分别从1编到N。
第二行包含N个整数,代表这N个学生的初始成绩,其中第i个数代表ID为i的学生的成绩。
接下来有M行。每一行有一个字符 C (只取'Q'或'U') ,和两个正整数A,B。
当C为'Q'的时候,表示这是一条询问操作,它询问ID从A到B(包括A,B)的学生当中,成绩最高的是多少。
当C为'U'的时候,表示这是一条更新操作,要求把ID为A的学生的成绩更改为B。
 

Output
对于每一次询问操作,在一行里面输出最高成绩。
 

Sample Input
 
 
5 61 2 3 4 5Q 1 5U 3 6Q 3 4Q 4 5U 2 9Q 1 5
 

Sample Output
 
 
5659


    代码(模版):

           

#include <iostream>
#include <cmath>
using namespace std;
const int MaxNood = 1 << 19;
const int Maxn = 2e6 +10;

struct Node {
    int val;
    int left, right;
}node[MaxNood];

int father[Maxn];

void BuildTree (int i, int left, int right){
    node[i].left = left;
    node[i].right = right;
    node[i].val = 0;
    if(left == right){
        father[left] = i;
        return ;
    }
    BuildTree (i << 1, left, (int)(floor (left + right)/2.0));
    BuildTree ((i << 1) +1, (int)(floor (left + right)/2.0) + 1, right);
}

void UpdateTree (int ri){
    if(ri == 1) return ;
    int fi = ri / 2;
    int a = node[fi << 1].val;
    int b = node[(fi << 1)+1].val;
    node[fi].val = max (a,b);
    UpdateTree (ri/2);
}

int Max ;

void search (int i, int l, int r){
    if(node[i].left == l && node[i].right == r){
        Max = max (Max, node[i].val);
        return ;
    }
    i = i<<1;
    if(l <= node[i].right){
        if (r <= node[i].right){
            search (i , l ,r);
        }
        else{
            search (i, l, node[i].right);
        }
    }
    i++;
    if(r >= node[i].left){
        if (l >= node[i].left){
            search (i, l ,r);
        }
        else{
            search (i,node[i].left, r);
        }
    }
}

int main (){
    ios::sync_with_stdio(false);
    int n, m ,k;
    while (cin >>n >>m){
        BuildTree (1, 1, n);
        for (int i = 1; i<= n; i++){
            cin >> k;
            node[father[i]].val = k;
            //cout << father[i] << endl;
            UpdateTree (father[i]);
        }
        string op;
        int a,b;
        while (m--){
            cin >> op >> a >> b ;
            if(op[0] == 'Q'){
                Max = 0;
                search (1,a,b);
                cout << Max << endl ;
            }
            else{
                node[father[a]].val = b;
                UpdateTree (father[a]);
            }
        }
    }
    return 0;
}

这个题要是使用C++写的话,需要关闭同步,在主函数中写上ios::sync_with_stdio(false);  ,就可以了。卡了一下时间,如果不写的话就只能Time Limit Exceeded了,但是使用C语言就没什么问题了。

评论 4
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值