poj 2528 线段树区间合并

点击打开链接 poj 2528

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters' size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers l i and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= l i <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered l i, l i+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

题目大意:

就是给你一张海报,在每个区间都会去张贴海报,并且后贴的会把之前贴的覆盖掉,让你求可以看到多少张海报。


刚开始就是认为线段树的区间合并问题,但是这个题困了我好久,就是因为需要离散化,之前也接触过离散化,但是不常用,所以看了下别人的代码,刚开始看怎么也看不懂,最后把每一步输出出来看看还是可以懂的。

原来的是(1,4),(2,6),(8,10),(3,4),(7,10),通过离散化之后把这些区间改边成(1,4),(2,5),(7,8),(3,4),(6,8)。

经过很长时间完成后的代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define lson l,mid,ri<<1
#define rson mid +1 ,r,ri<<1|1

int n,cnt;
const int maxn = 1e5+10;

struct Node{
    int l,r,n;
} a[maxn<<2];

struct node{
    int point,num;
} s[maxn<<2];

int map[maxn<<1][2],ans,vis[maxn<<1];

int cmp(node x,node y){
    return x.point<y.point;
}

void Build(int l,int r,int ri){
    a[ri].l = l;
    a[ri].r = r;
    a[ri].n = 0;
    if (l == r){
        return ;
    }
    int mid = (l+r)>>1;
    Build(lson);
    Build(rson);
}

void insert(int ri,int l,int r,int m){
    if(a[ri].l == l && a[ri].r == r){
        a[ri].n = m;
        return;
    }
    int mid = (a[ri].l+a[ri].r)>>1;
    if(a[ri].n>0){
        a[ri<<1].n = a[ri<<1|1].n = a[ri].n;
        a[ri].n = 0;
    }
    if(l>=a[ri<<1|1].l)
        insert(ri<<1|1,l,r,m);
    else if(r<=a[ri<<1].r)
        insert(ri<<1,l,r,m);
    else{
        insert(ri<<1,l,mid,m);
        insert(ri<<1|1,mid+1,r,m);
    }
}

void solve(int ri){
    if(a[ri].n){
        if(!vis[a[ri].n]){
            ans++;
            vis[a[ri].n] = 1;
        }
        return;
    }
    solve(ri<<1);
    solve(ri<<1|1);
    return;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i = 0; i < n; i++){
            scanf("%d%d",&map[i][0],&map[i][1]);
            s[i<<1].point = map[i][0];
            s[i<<1|1].point = map[i][1];
            s[i<<1].num = -(i+1);
            s[i<<1|1].num = i+1;
        }
//        for (int i = 0; i < 2*n; i++){
//            printf("%d %d %d\n",i,s[i].point,s[i].num);
//        }
        sort(s,s+2*n,cmp);
//        printf("\n");
//        for (int i = 0; i < 2*n; i++){
//            printf("%d %d %d\n",i,s[i].point,s[i].num);
//        }
        int temp = s[0].point,cnt = 1;
        for(int i = 0; i < 2*n; i++){
            if(temp != s[i].point){
                cnt++;
                temp = s[i].point;
            }
            if(s[i].num < 0)
                map[-s[i].num-1][0] = cnt;
            else
                map[s[i].num-1][1] = cnt;
        }
        Build(1,cnt,1);
        for(int i = 0; i < n; i++){
//            printf("%d %d\n",map[i][0],map[i][1]);
            insert(1,map[i][0],map[i][1],i+1);
        }
        memset(vis,0,sizeof(vis));
        ans = 0;
        solve(1);
        printf("%d\n",ans);
    }

    return 0;
}
多多努力,加油加油!
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值