A Needle in the Haystack SPOJ - NHAY

Write a program that finds all occurences of a given pattern in a given input string. This is often referred to as finding a needle in a haystack.

The program has to detect all occurences of the needle in the haystack. It should take the needle and the haystack as input, and output the positions of each occurence, as shown below. The suggested implementation is the KMP algorithm, but this is not a requirement. However, a naive approach will probably exceed the time limit, whereas other algorithms are more complicated... The choice is yours.

Input

The input consists of a number of test cases. Each test case is composed of three lines, containing:

  • the length of the needle,
  • the needle itself,
  • the haystack.

The length of the needle is only limited by the memory available to your program, so do not make any assumptions - instead, read the length and allocate memory as needed. The haystack is not limited in size, which implies that your program should not read the whole haystack at once. The KMP algorithm is stream-based, i.e. it processes the haystack character by character, so this is not a problem.

The test cases come one after another, each occupying three lines, with no additional space or line breaks in between.

Output

For each test case your program should output all positions of the needle's occurences within the haystack. If a match is found, the output should contain the position of the first character of the match. Characters in the haystack are numbered starting with zero.

For a given test case, the positions output should be sorted in ascending order, and each of these should be printed in a separate line. For two different test cases, the positions should be separated by an empty line.

Example

Sample input:
2
na
banananobano
6
foobar
foo
9
foobarfoo
barfoobarfoobarfoobarfoobarfoo
Sample output:
2
4

3
9
15
21

Note the double empty line in the output, which means that no match was found for the second test case.

Warning: large Input/Output data, be careful with certain languages

 

题目大意: 就是输出第一个字符串在第二个字符串中出现的位置,没有的就输出一个空格

本来一直在练习哈希,结果发现题目里说了句KMP。。。于是果断KMP水掉。。。

/*
@Author: Top_Spirit
@Language: C++
*/
#include <bits/stdc++.h>
#include <unordered_map>
using namespace std ;
const int Maxn = 1e6 + 10 ;
const int INF = 0x3f3f3f3f ;

char s1[Maxn], s2[Maxn] ;
int Next[Maxn] ;
int len, n ;

void Get_Next(){
    Next[0] = -1 ;
    int k = -1, j = 0 ;
    while (j < n){
        if (k == -1 || s1[j] == s1[k]) Next[++j] = ++k ;
        else k = Next[k] ;
    }
}

void KMP (){
    int i = 0, j = 0 ;
    while (i < len){
        if (j == -1 || s1[j] == s2[i]){
            i++ ;
            j++ ;
        }
        else j = Next[j] ;
        if (j == n){
            cout << i - n << endl ;
        }
    }
}

int main (){
    while (~scanf("%d", &n)){
        scanf("%s%s", s1, s2) ;
        len = strlen(s2) ;
        if (n > len){
            puts("") ;
            continue ;
        }
        Get_Next() ;
        KMP() ;
    }
    return 0 ;
}

每天早上醒来,看见阳光和你都在

那就是我想要的未来

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值