PAT 1053 Path of Equal Weight (30 分)

1053 Path of Equal Weight (30 分)

Given a non-empty tree with root R, and with weight W i W_i Wi assigned to each tree node T i T_i Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.
Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in the following figure: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in the figure.
在这里插入图片描述


Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N≤100, the number of nodes in a tree, M (<N), the number of non-leaf nodes, and 0<S< 230 2{30} 230, the given weight number. The next line contains N positive numbers where W i W_i Wi(<1000) corresponds to the tree node T i T_i Ti. Then M lines follow, each in the format:
ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.


Output Specification:
For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.Note: sequence { A 1 A_1 A1, A 2 A_2 A2,⋯, A n A_n An} is said to be greater than sequence { B 1 B_1 B1, B 2 B_2 B2,⋯, B m B_m Bm} if there exists 1≤k<min{n,m} such that A i A_i Ai= B i B_i Bi for i=1,⋯,k, and A k + 1 A_{k+1} Ak+1>$B_{k+1}.

Sample Input:

20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19

Sample Output:

10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2




解析

问一条路径的和是否为Sum。好像LeetCode也有一道很类似的。112:Path Sum
这题我用的是DFS。但是常规的DFS是不能满足我的需要的。所以我写了一个DFShelp函数。

void DFShelp(vector<int>& Path,int len,int n, int s) {
	if (s == Node[n].weight && Node[n].child.empty()) {
		for (int i = 0; i < len; i++)
			printf("%d ", Node[Path[i]].weight);
		printf("%d\n",Node[n].weight);
	}
	else if (s < Node[n].weight)   //回溯剪枝
		return;
	else {                         //继续深入
		Path[len] = n;
		for (auto x : Node[n].child) {
			DFShelp(Path, len + 1, x, s - Node[n].weight);
		}
	}
}

因为输出的路径权重 要按降序,所以可以在DFS之前:给每一个结点的子节点排序。



Code:

#include<algorithm>
#include<functional>
#include<cstdio>
#include<iostream>
#include<queue>
#include<string>
#include<cmath>
const int maxn = 101;
using namespace std;
int LayerTable[101]{0};
struct node {
	int weight;
	vector<int> child;
	node() :weight(0) {	}
}Node[maxn];
void DFShelp(vector<int>& Path,int len,int n, int s) {
	if (s == Node[n].weight && Node[n].child.empty()) {
		for (int i = 0; i < len; i++)
			printf("%d ", Node[Path[i]].weight);
		printf("%d\n",Node[n].weight);
	}
	else if (s < Node[n].weight)
		return;
	else {
		Path[len] = n;
		for (auto x : Node[n].child) {
			DFShelp(Path, len + 1, x, s - Node[n].weight);
		}
	}
}
void DFS(int n,int s) {
	vector<int> Path(101,0);
	DFShelp(Path,0,n,s);
}
int main()
{
	int N, M, S;
	scanf("%d %d %d", &N, &M, &S);
	for (int i = 0; i < N; i++)
		scanf("%d", &Node[i].weight);
	for (int i = 0; i < M; i++) {
		int father, K, son;
		scanf("%d %d", &father, &K);
		for (int i = 0; i < K; i++) {
			scanf("%d", &son);
			Node[father].child.push_back(son);
		}
	}
	for (int i = 0; i < N; i++)
		sort(Node[i].child.begin(), Node[i].child.end(), [](int a, int b) {
															return Node[a].weight > Node[b].weight; });
	DFS(0,S);
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值