tensorflow2.0+cudnn更改版本及版本查看

tensorflow 版本回退/cudnn版本更改

tensorflow 版本回退

原来的tensorflow 版本为2.0,由于此版本无tensorflow.contrib ,所以对退到1.13.1。

#先删除旧版本的tensorflow
pip uninstall protobuf
pip uninstall tensorflow
#安装新版本
pip install tensorflow-gpu==1.13.1

cudnn版本更改

原先的cudnn为7.6.4,不适用与tensorflow1.13.1。不更改会报错,所以官网下载7.3.1版本的cudnn,可用。

cudnn版本查看
我找到查看cudnn版本的方式大多为代码的形式,偶然打开cudnn.h这个文件,和原先旧版本的对比了发现这个应该就代表版本7.3.1
这个应该就代表版本7.3.1
版本7.6.4
版本7.6.4

如有错误,欢迎指出!

发布了7 篇原创文章 · 获赞 0 · 访问量 237
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 大白 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览