设计函数int sqrt(int x),计算 xx 的平方根。 输入格式 输入一个 整数 xx,输出它的平方根。直到碰到文件结束符(EOF)为止。

设计函数int sqrt(int x),计算 x 的平方根。

输入格式

输入一个 整数 xx,输出它的平方根。直到碰到文件结束符(EOF)为止。

输出格式

对于每组输入,输出一行一个整数,表示输入整数的平方根。

样例输入
1
2
3
4
5
6
7
8
9

样例输出
1
1
1
2
2
2
2
2
3

这里的 EOFscanner.hasNext() 表示:hasNext() 的作用就是判断是否还有下一个元素,以 ctrl+z 结束。
好了开始写代码。。。。。这里直接用它提供的Math.sqrt(x); 完事


import java.util.ArrayList;
import java.util.Scanner;

public class Main {
	public static void main(String[] args) {
		Main replaces = new Main();

		Scanner scanner = new Scanner(System.in);
		int input;
		ArrayList<Integer> list = new ArrayList<Integer>();
		int n = 0;
		while (scanner.hasNext()) {
			input = scanner.nextInt();
			list.add(replaces.sqrt(input));

		}
		for (int i = 0; i < list.size() - 1; i++) {
			System.out.println(list.get(i));
		}
		System.out.print(list.get(list.size() - 1));

	}

	public int sqrt(int x) {

		return (int) Math.sqrt(x);
	}

}

  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值