Farmer John is an astounding accounting wizard and has realized he might run out of money to run the farm. He has already calculated and recorded the exact amount of money (1 ≤ moneyi ≤ 10,000) that he will need to spend each day over the next N (1 ≤ N ≤ 100,000) days.
FJ wants to create a budget for a sequential set of exactly M (1 ≤ M ≤ N) fiscal periods called "fajomonths". Each of these fajomonths contains a set of 1 or more consecutive days. Every day is contained in exactly one fajomonth.
FJ's goal is to arrange the fajomonths so as to minimize the expenses of the fajomonth with the highest spending and thus determine his monthly spending limit.
Input
输入
Line 1: Two space-separated integers: N and M
Lines 2..N+1: Line i+1 contains the number of dollars Farmer John spends on the ith day
输出
Line 1: The smallest possible monthly limit Farmer John can afford to live with.
样例输入
7 5
100
400
300
100
500
101
400
样例输出
500
最大值最小化,和最小值最大化是acm竞赛中两中常见的题型;
这题,我们将采用二分的方法,上限为总量,下限为单个最大量,在二分过程中不断计数少于mid的方案,找到最小不断循环直至找到。
#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>
#include <climits>
#include<queue>
#include<vector>
#include <string.h>
#include <math.h>
#include<map>
#include<string.h>
#define ll long long
using namespace std;
int a[100005];
int main()
{
int n,m;
int sum,maxx,i,s,cnt,mid;
while(scanf("%d%d",&n,&m)!=EOF)
{
sum = 0,maxx = 0;
for(i = 0; i<n; i++)
{
scanf("%d",&a[i]);
sum+=a[i];
maxx = max(maxx,a[i]);
}
while(maxx<sum)
{
mid = (sum+maxx)/2;
s = 0,cnt = 0;
for(i = 0; i<n; i++)
{
s+=a[i];
if(s>mid)
{
s = a[i];
cnt++;
}
}
if(cnt<m) sum = mid;
else maxx = mid+1;
}
printf("%d\n",maxx);
}
return 0;
}