PAT 甲级 1012 The Best Rank (25分)

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algrbra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of CME and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input Specification:

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (≤2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of CM and E. Then there are M lines, each containing a student ID.

Output Specification:

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output N/A.

Sample Input:

5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999

Sample Output:

1 C
1 M
1 E
1 A
3 A
N/A
这道题由于学生的数量过少,只有2000个,所以随便的进行模拟都可以的
注意一点: 在排序的时候,相同的分数的排名相同,即会出现这样的排名 1,1,3,4

实现上述的排名方式:
    stu[0].best_e = 1;    
    for (int i = 1; i < n; ++i){
        if (stu[i].e == stu[i - 1].e)
            stu[i].best_e = stu[i - 1].best_e;
        else
            stu[i].best_e = i + 1;        
    }
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
using namespace std;

struct student{
    string id;
    double c;
    double m;
    double e;
    double a;
    int best_a = 0;
    int best_c = 0;
    int best_m = 0;
    int best_e = 0;
}stu[100000];

set<string> s;

bool cmp1(student x,student y){
    return x.a > y.a;
}

bool cmp2(student x,student y){
    return x.c > y.c;
}

bool cmp3(student x,student y){
    return x.m > y.m;
}

bool cmp4(student x,student y){
    return x.e > y.e;
}

int main(){

    int n,m; string id;
    cin >> n >> m;

    for (int i = 0; i < n; ++i){
        double c,m,e,a;
        cin >> id >> c >> m >> e;
        a = (c + m + e) / 3.0;
        stu[i] = {id,c,m,e,a};
        s.insert(id);
    }

    sort(stu,stu + n,cmp1);

    stu[0].best_a = 1;
    for (int i = 1; i < n; ++i){
        if (stu[i].a == stu[i - 1].a)
            stu[i].best_a = stu[i - 1].best_a;
        else
            stu[i].best_a = i + 1;
    }

    sort(stu,stu + n,cmp2);

    stu[0].best_c = 1;    
    for (int i = 1; i < n; ++i){
        if (stu[i].c == stu[i - 1].c)
            stu[i].best_c = stu[i - 1].best_c;
        else
            stu[i].best_c = i + 1;        
    }

    sort(stu,stu + n,cmp3);

    stu[0].best_m = 1;    
    for (int i = 1; i < n; ++i){
        if (stu[i].m == stu[i - 1].m)
            stu[i].best_m = stu[i - 1].best_m;
        else
            stu[i].best_m = i + 1;        
    }

    sort(stu,stu + n,cmp4);

    stu[0].best_e = 1;    
    for (int i = 1; i < n; ++i){
        if (stu[i].e == stu[i - 1].e)
            stu[i].best_e = stu[i - 1].best_e;
        else
            stu[i].best_e = i + 1;        
    }

    for (int i = 0; i < m; ++i){
        cin >> id;
        if (s.count(id) == 0){
            puts("N/A");
            continue;
        }
        for (int i = 0; i < n; ++i){
            if (id == stu[i].id){
                int top_rank = stu[i].best_a;
                int top_sub = 'A';
                if (top_rank > stu[i].best_c){
                    top_sub = 'C';
                    top_rank = stu[i].best_c;
                }
                if (top_rank > stu[i].best_m){
                    top_sub = 'M';
                    top_rank = stu[i].best_m;
                }                
                if (top_rank > stu[i].best_e){
                    top_sub = 'E';
                    top_rank = stu[i].best_e;
                }
                cout<<top_rank<<" "<<char(top_sub)<<endl;                
            }
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值