易语言的学习

官网下载:http://www.dywt.com.cn/pdown.htm  官网最新版本为:5.8

不买正版:吾爱破解论坛  搜索:易语言 免安装    破解版版本为:5.3

https://www.52pojie.cn/thread-418864-1-1.html

学习路径:

1先建个易语言窗口:

2、选择windows窗口

3、点击编译----静态编译

4、保存运行文件

5、应用第三方支持库

选择工具---支持库配置----mysql安装

6、帮助----支持库手册及例程,下载演示视频(授人以鱼并授人以渔)

7、阶段性总结(预习新知识,入门巩固并且提高)

控件、命令

窗口控件、

编辑框控件、

按钮控件、

标签控件、基本代码编写

猜数字

熟悉易语言的编程环境

编写规范化代码---易阅读的代码(名称)

命令的使用:1、置随机数种子2、取随机数3、信息框

命令就是功能。

什么是参数?

参数是实现功能所需的东西

 

添加变量

变量的类型----局部变量-----全局变量---程序集变量

1、添加程序集变量:放在窗口程序集下面,子程序名上面

2、添加局部变量(ctrl+L):插入---局部变量

3、a1=10回车选择变量类型、

判断输入

控件的事件

控件的属性

流程控制命令----如果-VS判断(更加美观)

不能将文本型数据和整数型比较的(到整数(编辑框文本))转换成整数

屏蔽(ctrl+k)----解除屏蔽(ctrl+m)

信息框(提示)

易语言的符号支持中文 英文

右击终止运行(Ctrl+F5),才能删除命令行

1、熟悉以语言的操作界面

2、熟悉了软件的编程流程和思路

3、窗口和一般控件的使用

4、流程控制命令的使用(判断)

5、命令的使用(信息框、取随机数)

6、变量的使用(用来存储随机数)

窗口组件

重新生成

计算器

(四舍五入、求余数)

加入文本:把想加入的话加入到编辑框中

文本型需加入“”

变量的类型:

字节型、整数型(短整数型、长整数型)、文本型、数值型(小数型、双精度小数型)、逻辑性、日期时间型、字节集型、子程序指针型

帮助---易语言知识库

系统基本数据类型列表及其说明如下:

1、字节型。可容纳 0 到 255 之间的数值。

2、短整数型。可容纳 -32,768 到 32,767 之间的数值,尺寸为 2 个字节。

3、整数型。可容纳 -2,147,483,648 到 2,147,483,647 之间的数值,尺寸为 4 个字节。

4、长整数型。可容纳 -9,223,372,036,854,775,808 到 9,223,372,036,854,775,807 之间的数值,尺寸为 8 个字节。

5、小数型。可容纳 3.4E +/- 38 (7位小数) 之间的数值,尺寸为 4 个字节。

6、双精度小数型。可容纳 1.7E +/- 308 (15位小数) 之间的数值,尺寸为 8 个字节。

7、逻辑型。值只可能为“真”或“假”,尺寸为 2 个字节。“真”和“假”为系统预定义常量,其对应的英文常量名称为“true”和“false”。

8、日期时间型。用作记录日期及时间,尺寸为 8 个字节。

9、文本型。用作记录一段文本,文本由以字节 0 结束的一系列字符组成。

10、字节集。用作记录一段字节型数据。字节集与字节数组之间可以互相转换,在程序中允许使用字节数组的地方也可以使用字节集,或者相反。字节数组的使用方法,譬如用中括号对(“[]”)加索引数值引用字节成员,使用数组型数值数据进行赋值等等,都可以被字节集所使用。两者之间唯一的不同是字节集可以变长,因此可把字节集看作可变长的字节数组。

11、子程序指针。用作指向一个子程序,尺寸为 4 个字节。具有此数据类型的变量可以用来间接调用子程序。参见例程 sample.e 中的相应部分。

  在以上的基本数据类型中,字节型、短整数型、整数型、长整数型、小数型、双精度小数型被统称为“数值型”,它们之间可以任意转换。不过编程需要注意转换可能带来的精度丢失。譬如:将整数 257 转换为字节后的结果为 1 ,这是因为值 257 超出了字节型数据的最大上限 255 ,从而产生了溢出。

另外,通用型数据类型仅在系统内部使用,它能够匹配所有的系统基本数据类型、库定义数据类型、自定义数据类型。

转换丢失精度

易语言帮助文档下载(迅雷、qq旋风)http://www.dywt.com.cn/edown/esdn.rar

F1查看即使帮助,F5运行预览

易语言源码(交易币定制软件)

精易论坛http://bbs.125.la/

9*9乘法表

流程控制--循环命令

1、循环命令(计次循环命令、变量循环命令)

2、循环控制(到循环尾、跳出循环)

编辑框.加入文本(“1”)

软件登录界面的制作

到全角、到半角

 

制作闹钟

新的窗口组件时钟(有且仅有一个事件---时钟周期)

时间操作命令、(时钟周期:1000每个一秒执行一次;)

局部_时间 = 取现行时间 ()

.如果真 (局部+时间 = 程序集_时间)

    ' 信息框 (“当前时间已到”, 0, , )

    播放MP3 (, “1.mp3”)

.如果真结束

 

托盘图标与菜单

添加图片资源

启动窗口----右击----菜单编辑器

右键弹出菜单---->向后插入----->右移----->...显示主程序--->向后插入--->关于程序--->向后插入---->退出---->确定

_启动窗口托盘事件

关于程序.禁止 = 真

_启动窗口.置托盘图标 (#图片_托盘图标, )

点击-显示主程序

_启动窗口.可视 = 真

_启动窗口.置托盘图标 (, )

.版本 2

输出调试文本 (操作类型)

.判断开始 (操作类型 = #单击右键)

    关于程序.禁止 = 真

弹出托盘菜单 (右键弹出菜单)

信息框 (“这是我的一个托盘菜单程序”, 0, , )

销毁 ()

学生成绩管理系统

1、了解数组

2、可重复添加参数命令                      动态链接库(dynamic link library)

编辑框_输出.加入文本 (#换行符)  #换行符     

易语言的数组从1开始[1],不能让数组超过范围或小于等于0

文件浏览器

添加子程序快捷键(ctrl+N),子程序是不能重名的

当你碰见一个窗口组建的时候,你首先应该先看它的属性。(右键,查看数据类型定义)

寻找文件 (编辑框_目录.内容 + “\” + “*.e”, )每次只会寻找出一个出来

.表示当前目录;..表示上级目录

子程序的使用方法

添加按钮--->双击---->自动生成子程序   案例:

系统自动生成的子程序,不能修改参数

理解子程序参数的属性

(把子目录中的文件也取出来)

生成自己的子程序  参数(参考、可空、数组、备注)

递归和循环

到循环尾-------不循环

 

 

 

    .如果真 (文件名 = “.” 或 文件名 = “..”)

        文件名 = 寻找文件 (1 + 2 + 4 + 16 + 32, )

        到循环尾 ()

1、第一个参数代表“文本型 欲寻找的文件或目录名称”、第二个参数代表“整数型 欲寻找文件的属性”

文件名 = 寻找文件 (查找的目录 + “*.*”, 1 + 2 + 4 + 16 + 32)

2、第一个参数不填,表示继续找

文件名 = 寻找文件 (, 1 + 2 + 4 + 16 + 32)

3、取文件属性 ()

判断是否是子目录

(如果真 (取文件属性 (查找的目录 + 文件名) = #子目录))

4、子程序_查找文件 (查找的目录 + 文件名)

使用树形框组件来完善文件浏览器

工具----支持库配置

加入到树形框当中

树形框1.加入项目(,找到的文件名,,,,,)

 

 

 

 

打造自己的进程管理器

模块开发(扩展支持库一2.0版)

引用精易模块(进程)

状态条(右键设置项目)

状态条1.置文本 (1, 到文本 (取数组成员数 (进程名数组)))

 

.判断开始 (_启动窗口.总在最前 = 真)

    _启动窗口.总在最前 = 假

    保持在前端.选中 = 假

.默认

 

    _启动窗口.总在最前 = 真

    保持在前端.选中 = 真

 

 

 

 

 

能力提高:模拟红绿灯程序

.如果真 (程序集_绿灯亮的时间 ≤ 4)

外形框_绿.可视 = 取反 (外形框_绿.可视)

能力提高:分割文本与超级列表框

读取指定的文本文件

 

读取网页内容加入到列表框

提交信息 = 编码_utf8到gb2312 (到文本 (网页_访问 (“http://login.vboly.com/web/user/login.htm”, 1, “loginname=” + 编辑框1.内容 + “&password=” + 编辑框2.内容, cookie1, cookie2)))

把没有意义的代码去除掉,找到唯一的代码(去除掉)

认识了解窗口句柄

1、认识并了解窗口句柄

2、寻找窗口,获取窗口信息

3、认识并学习API的使用

 

1、什么是句柄?窗口句柄是用来标志窗口的唯一值。每个窗口对应一个句柄,虽偶有的句柄都不会重复

2、如何通过句柄获取、操作窗口位置和其他信息

 

什么是API?API是应用程序编程接口。他通常是系统提供给我们用来进行编程的封装好的功能,我们可以直接对接使用。

 

如何查看和使用API进行编程?

1、通过API助手查看函数(易用API伴侣、getwindowtext

2、在论坛上面查找例程

3、在搜索引擎中进行搜索获得使用方法

开始编写程序:

使用API(DLL命令)

通过类名或者标题获取指定窗口的句柄。

FindWindow

获取窗口的大小位置:GetWindowRect

获取窗口的标题GetWindowText:

1、仔细看第二和第三个参数,为什么他会要求传递一个文本型缓冲区和长度?

2、这样的参数该如何进行填写?

 

课后作业:

多动手,多翻阅API文档,查看更多的API内容。动手自己试一试

思考部分:将程序改写为“记事本”的。并且在窗口中添加一个按钮,当点击按钮之后,在记事本窗口中显示“易语言”

精易编程助手下载地址:http://soft.125.la/plugin.php?id=jingyi_soft:soft&cid=3

 

简易的QQ快捷回复

1、继续巩固上节课的内容

2、判断窗口的前后关系

3、程序的逻辑处理

 

1、获取到QQ的聊天句柄

2、判断当前窗口是不是聊天窗口

3、当前窗口是QQ窗口   当前窗口不是QQ  隐藏窗口   当前窗口是自身 什么都不做 循环操作 

4、将窗口“贴”到聊天窗口旁

 

开始编写程序

获取所有的窗口句柄。EnumWindows

通过美剧,获取系统中所有的窗口句柄

注意:他是一个回调的用法。需要我们传递一个子程序地址,这个函数没找到一个窗口,就会自动调用我们给他的子程序指针,相当于调用我们的子程序。同时需要注意的是,这个子程序有明确的格式,必须按照格式来写。

 

获取当前“前台”窗口句柄:GetForegroundWindow

这里的“前台窗口”是指前台应用程序的活动窗口

 

设置窗口到“前台”:SetForegroundWindow

通过窗口来取类名(GetClassName)

1、先在易用API伴侣查找EnumWindows复制

2、新建程序窗口,添加按钮,双击进入代码,粘贴

3、程序--dll查看命令名:API_枚举父窗口(函数指针,自定义数值)

 

枚举型一个一个的去找窗口,通知结果

设置一个子程序回调通知结果。

回调_查找句柄(当前找到的窗口句柄,附加参数)

到一定时期,系统会自动调用。

& 代表“地址符号” &回调查找窗口句柄子程序

根据窗口来找类名:getclassname

获取窗口标题:getwindowtext

取空白文本:就是取空格,为存放其他内容先开启一个缓冲区。

哪里能输入哪里就是前台

获取前台,设置前台

获取前台窗口句柄:GetForegroundWindow

标签1.标题=到文本()

编辑框1.内容=

能力提高:程序调试

输出调试文本与调试输出

1、他们有什么区别?

输出调试文本是核心支持库中的命令

调试输出是第三方支持库“特殊功能支持库”中的命令

 

输出调试文本不能直接输出数组和字节集的数据

调试输出可以直接输出数组,字节集的详细信息

2、调试输出功能更加强大

 

暂停程序执行进入调试模式

1、暂停和断点

暂停是代码,需要写在代码编写区域。不可以随时取消。断点是手动设置的,可以随时修改取消。

暂停 ()

断点可以设置为条件断点--在制定的条件成立时暂停执行。暂停则不可以,每次执行都会暂停。

最左侧向下箭头右键“设置或清除断点”,一般用在循环里面(条件断点)

2、但不调试,查看程序执行状态

跟踪执行状态:

单步跟踪(F8),单步跟踪进入(shift+F8)

 

查看程序信息:

查看监视,调用,变量表

点击监视表右键--添加变量,就可监视到监视表

调用--在子程序添加断点,运行程序,即可看到程序的调用情况

变量表

3、检查与验证

检查一个指定的条件是否成立,如果不成立则暂停执行,进入调试模式

 

下断点

程序中短时单步调试并查看变量状态

认识数据库

下载:sqlite studio

http://sqlitestudio.pl/index.rvt?act=download

 

数据库专题:开始设计例程1

1、制作一个知识笔记小程序

2、SQLite3数据库的创建和使用

3、表的设计和创建

4、使用易语言来创建数据库和表

 

设计表:

1、ID  用来区分每一条记录、主键

2、项目标题  记录项目的标题

3、项目的说明   一些关于项目的说明,以后查找是使用

4、具体内容   记录详细内容

5、项目类型   项目的类型,例如:

使用易语言创建数据库和表

1、Sqlite3支持库:Sqlite3数据库、Sqlite3字段

2、使用类:易语言总的类、为什么使用类、为何创建和编写类

程序

程序数据右键“新类模块”

类以变量方式使用

类需要调用累的方法才能在程序中使用

只有在类里边才叫做方法

 

数据库专题:开始设计例程2

1、开始设计程序

2、设计和字段对应的数据类型

根据已有的表中字段的结构设计自定义数据类型

SQL语句->插入一条记录

Sqlite3表操作->插入一条记录

将加入记录的代码用易语言实现

1、右键点击新数据类型(添加和数据库表格字段匹配的类型)

 

3、在数据库类模块里右键,点击新方法

使用易语言创建数据库和表

1、自定义数据类型

1、创建自定义数据据类型

2、自定义数据;类型中的成员

3、自定义数据类型作为参数和返回值

2、SQL语句使用

1、什么是SQL(结构话查询语言)

2、如何使用SQl

http://www.w3school.com.cn/sql/

快速添加调试断点(F9)

SQL写语句介绍

一、数据查询语言(DQL:Data Query Language):

其语句,也称为“数据检索语句”,用以从表中获得数据,确定数据怎样在应用程序给出。保留字SELECT是DQL(也是所有SQL)用的最多的动词,注意常见的DQL有WHERE

二、数据操作语言(DML:Data Manipulation Language):

其语句包括动词INSERT,UPDATE和DELETE。他们分别用于添加,修改和删除表中的行。也成为动作查询语言。

三、事务处理语言(TPL):

他的语句能确保被DML语句影响的表的所有行及时得以更新。TPL语句包括BEGIN TRANSATION,COMMIT和ROLLBACK。

 

完善类的功能

开始编写软件

1、设计软件界面和功能

2、将“类”引用到程序中

抓包工具的选择

post_get网页请求介绍

1、Cookie

当我们在网站登录后网站会返回cookie,相当于临时身份证

1、数据抓包工具(F2使用教程及介绍)

IE浏览器的HTTPwach插件工具(汉化)http analyzer v7(同为抓包工具)

浏览器的F2(一般均为谷歌内核--极速内核)

其他类型的抓包工具 入:Wireshark(鲨鱼),WSExolorer程序抓包工具

2、配合工具

精易助手 (编码查询正则匹配等边界工具)

发包工具 (快速的进行发包测试,提高工作效率,无需浪费时间写代码)

在线工具网站 (如一些JSON格式解析http://json.cn/等等类型网站)

3、其他工具

手机请求抓包:FD(fiddle)鲨鱼也可以

(通过配置FD,可以对整机以及进行数据抓包,HTTP以及HTTPS进行抓包)

(HTTP是明文传输,而HTTPS是通过ssl加密数据传输,相对来说更加安全)

4、协议头解答

5、WinHTTP对象

在番外篇进行详细介绍,如何新疆不以及方法调用处理,本站使用网页_访问_对象。

 

IE浏览器顶部右键点击“菜单栏”显示工具

多线程的使用

线程句柄是一个全局变量

设置菜单,添加通用对话框组件

音乐播放器的组成部分

 

 

  • 1
    点赞
  • 0
    评论
  • 12
    收藏
  • 打赏
    打赏
  • 扫一扫,分享海报

参与评论 您还未登录,请先 登录 后发表或查看评论
©️2022 CSDN 皮肤主题:大白 设计师:CSDN官方博客 返回首页

打赏作者

weixin_41631068

你的鼓励将是我创作的最大动力

¥2 ¥4 ¥6 ¥10 ¥20
输入1-500的整数
余额支付 (余额:-- )
扫码支付
扫码支付:¥2
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、C币套餐、付费专栏及课程。

余额充值