hdu1047-Integer Inquiry(高精度计算)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1047

题目原文:

 

Integer Inquiry

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25925    Accepted Submission(s): 7414


 

Problem Description

One of the first users of BIT's new supercomputer was Chip Diller. He extended his exploration of powers of 3 to go from 0 to 333 and he explored taking various sums of those numbers. 
``This supercomputer is great,'' remarked Chip. ``I only wish Timothy were here to see these results.'' (Chip moved to a new apartment, once one became available on the third floor of the Lemon Sky apartments on Third Street.) 

 

 

Input

The input will consist of at most 100 lines of text, each of which contains a single VeryLongInteger. Each VeryLongInteger will be 100 or fewer characters in length, and will only contain digits (no VeryLongInteger will be negative). 

The final input line will contain a single zero on a line by itself.

 

 

Output

Your program should output the sum of the VeryLongIntegers given in the input. 


This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

 

 

Sample Input

 

2


123456789012345678901234567890
123456789012345678901234567890
123456789012345678901234567890
0

99
9
999
0

 

Sample Output

 

370370367037037036703703703670

1107
 

 

题目大意:给出多个数据块,计算每一块的数据和。

解题思路:高精度加法,注意内存分配,注意输入输出格式。

AC代码:

#include <cstdio>
#include <cstring>
using namespace std;

const int N = 105;

typedef struct _BigInteger
{
    char val[N];
    void reverse();

    _BigInteger()
    {
        strcpy(val, "0");
    }

    void reset()
    {
        strcpy(val, "0");
    }

    void getInput()
    {
        scanf(" %s", this->val);
        this->reverse();
    }

    bool isZero()
    {
        return strlen(val) == 1 && val[0] == '0';
    }

    void add(const struct _BigInteger &otr); 
} BigInteger;


void BigInteger::reverse()
{
    int i = 0, l = strlen(this->val);
    while (i < l / 2)
    {
        char tc = this->val[i];
        this->val[i] = this->val[l - i - 1];
        this->val[l - i - 1] = tc;
        i++;
    }
}

void BigInteger::add (const BigInteger &otr)
{
    int la = strlen(this->val), lb = strlen(otr.val);
    int va, vb;
    int i = 0, c = 0;
    while (i < la || i < lb)
    {
        if (i < la) va = this->val[i] - '0';
        else va = 0;
        if (i < lb) vb = otr.val[i] - '0';
        else vb = 0;
        this->val[i++] = (va + vb + c) % 10 + '0';
        c = (va + vb + c) / 10;
    }
    if (c != 0) this->val[i++] = c + '0';
    this->val[i] = '\0';
}

int main()
{
    int T;
    scanf("%d", &T);
    BigInteger sum;
    BigInteger bi;
    while (T--)
    {
        sum.reset();
        while (bi.getInput(), !bi.isZero())
        {
            sum.add(bi);
        }
        sum.reverse();
        printf("%s\n", sum.val);
        if (T != 0) printf("\n");
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值