hdu2196-Computer(树形dp, 树上最远距离)

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=2196

题目原文:

Computer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 36215    Accepted Submission(s): 6062


 

Problem Description

A school bought the first computer some time ago(so this computer's id is 1). During the recent years the school bought N-1 new computers. Each new computer was connected to one of settled earlier. Managers of school are anxious about slow functioning of the net and want to know the maximum distance Si for which i-th computer needs to send signal (i.e. length of cable to the most distant computer). You need to provide this information. 



Hint: the example input is corresponding to this graph. And from the graph, you can see that the computer 4 is farthest one from 1, so S1 = 3. Computer 4 and 5 are the farthest ones from 2, so S2 = 2. Computer 5 is the farthest one from 3, so S3 = 3. we also get S4 = 4, S5 = 4.

 

 

Input

Input file contains multiple test cases.In each case there is natural number N (N<=10000) in the first line, followed by (N-1) lines with descriptions of computers. i-th line contains two natural numbers - number of computer, to which i-th computer is connected and length of cable used for connection. Total length of cable does not exceed 10^9. Numbers in lines of input are separated by a space.

 

 

Output

For each case output N lines. i-th line must contain number Si for i-th computer (1<=i<=N).

 

 

Sample Input

 

5
1 1
2 1
3 1
1 1

5
1 1
2 2
3 3
1 9

 

 

Sample Output

 

3
2
3
4
4
9
10
12
15
15

 

 题目大意:

        给一棵树,计算每个节点的能到达的最远距离。

解题思路:

        设 v 的子节点为 c,v 的父节点为 f。定义dp[i][0] 表示 i 节点子树的最远距离,dp[i][1] 表示 i 节点子树的次远距离,dp[i][2] 表示 i 节点的反向最远距离(即:i 节点的父节点不经过 i 节点的最远距离)maxc[i] 记录i节点最远距离经过的子节点。那么得到状态转移方程如下:

【1】:dp[v][0] = max { dp[ci][0] + dist(v, ci) }, maxc[v] = ci;

【2】:dp[v][1] = max { dp[ci][0] + dist(v, ci) }, maxc[v] != ci;

【3】:dp[v][2] = max { dp[f][1] + dist(f, v), dp[f][2] + dist(f, v) }, maxc[f] == v;

             dp[v][2] = max { dp[f][0] + dist(f, v), dp[f][2] + dist(f, v) }, maxc[f] != v;

 

         一开始想的是把【1】、【2】、【3】式分别用一个dfs计算,后来发现  【1】、【2】可以合并。

AC代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;

const int N = 10005;

int n;
vector<int> vec[N];
int dp[N][3];
int maxc[N];

void init()
{
	memset(dp, 0, sizeof(dp));
	memset(maxc, -1, sizeof(maxc));
	int i;
	for (i = 0; i <= n; i++)
	{
		vec[i].clear();
	}
}

void dfs(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		dfs(c);
		if (d + dp[c][0] >= dp[v][0])
		{
			dp[v][0] = d + dp[c][0];
			maxc[v] = c;
		}
	}
	// dfs2的内容合并到dfs1中
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c != maxc[v])
		{
			dp[v][1] = max(dp[v][1], d + dp[c][0]);
		}
	}
}

void dfs2(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c != maxc[v])
		{
			dp[v][1] = max(dp[v][1], d + dp[c][0]);
		}
		dfs2(c);
	}
}

void dfs3(int v)
{
	int i;
	for (i = 0; i < vec[v].size(); i += 2)
	{
		int c = vec[v][i];
		int d = vec[v][i + 1];
		if (c == maxc[v])
		{
			dp[c][2] = max(max(dp[c][2], d + dp[v][1]), d + dp[v][2]);
		}
		else 
		{
			dp[c][2] = max(max(dp[c][2], d + dp[v][0]), d + dp[v][2]);
		}
		dfs3(c);
	}
}

int main()
{
	while (scanf("%d", &n) != EOF)
	{
		init();
		int i, a, b;
		for (i = 2; i <= n; i++)
		{
			scanf("%d%d", &a, &b);
			vec[a].push_back(i);
			vec[a].push_back(b);
		}
		dfs(1);
		// dfs2(1);
		dfs3(1);
		for (i = 1; i <= n; i++)
		{
			printf("%d\n", max(dp[i][0], dp[i][2]));
		}
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值