Expressions——二叉树遍历

Problem Description

Arithmetic expressions are usually written with the operators in between the two operands (which is called infix notation). For example, (x+y)*(z-w) is an arithmetic expression in infix notation. However, it is easier to write a program to evaluate an expression if the expression is written in postfix notation (also known as reverse polish notation). In postfix notation, an operator is written behind its two operands, which may be expressions themselves. For example, x y + z w - * is a postfix notation of the arithmetic expression given above. Note that in this case parentheses are not required.

To evaluate an expression written in postfix notation, an algorithm operating on a stack can be used. A stack is a data structure which supports two operations:

1. push: a number is inserted at the top of the stack.
2. pop: the number from the top of the stack is taken out.
During the evaluation, we process the expression from left to right. If we encounter a number, we push it onto the stack. If we encounter an operator, we pop the first two numbers from the stack, apply the operator on them, and push the result back onto the stack. More specifically, the following pseudocode shows how to handle the case when we encounter an operator O:

a := pop();
b := pop();
push(b O a);
The result of the expression will be left as the only number on the stack.

Now imagine that we use a queue instead of the stack. A queue also has a push and pop operation, but their meaning is different:

1. push: a number is inserted at the end of the queue.
2. pop: the number from the front of the queue is taken out of the queue.
Can you rewrite the given expression such that the result of the algorithm using the queue is the same as the result of the original expression evaluated using the algorithm with the stack?

Input

The first line of the input contains a number T (T ≤ 200). The following T lines each contain one expression in postfix notation. Arithmetic operators are represented by uppercase letters, numbers are represented by lowercase letters. You may assume that the length of each expression is less than 10000 characters.

Output

For each given expression, print the expression with the equivalent result when using the algorithm with the queue instead of the stack. To make the solution unique, you are not allowed to assume that the operators are associative or commutative.

Sample Input

2

xyPzwIM

abcABdefgCDEF

Sample Output

wzyxIPM

gfCecbDdAaEBF

思路:https://www.cnblogs.com/shuzy/p/3183893.html

题目大意:给你一串字符,小写表示数字,大写字符表示运算符,碰到小写字符则进盏,碰到一个大写字符后,将前面两个数字出栈做一下运算后结果再压入栈中,直到结束。现在要求使用队列得到相同的运算结果,要求你求出应该按什么顺序输入。
输入:第一行一个整数t表示组数,接下来t行,为使用栈进行运算的输入序列。
输出:输出使用队列得到相同结果应该的输入序列。
分析:我们模拟栈进行运算建立一颗树,可以发现所要求的结果就是这颗树的层序遍历的逆序。

 

又是让我百思不得其解的问题,用char类型的字符串可以,string的就不可以???

代码 

#include<bits/stdc++.h>
using namespace std;

char s[10005],ans[10005];
//string s,ans;
stack<int> stk;

struct node{
	char val;
	int lef,rg;
}str[10005];

void bfs(int pos){
	queue<int> Q;
	Q.push(pos);
	int k=0;
	while(!Q.empty()){
		int i=Q.front();
		Q.pop();
		ans[k++]=str[i].val;
		if(str[i].lef!=str[i].rg){ //如果是叶节点(数),lef=rg=-1 
			Q.push(str[i].lef);
			Q.push(str[i].rg);
		}
	}
	while(pos>=0){
		cout <<ans[pos--];
	}
}

int main(){
	int t,i;
	cin>>t;
	while(t--){
		cin>>s;
		while(!stk.empty()) stk.pop();
//		int len=s.length();
		for(i=0;s[i];i++){
			if(islower(s[i])){
				stk.push(i);
				str[i].val=s[i];
				str[i].lef=str[i].rg=-1;
			}else{
				str[i].val=s[i];
				str[i].rg=stk.top();
				stk.pop();
				str[i].lef=stk.top();
				stk.pop();
				stk.push(i);
			}
		}
//		cout << i << " ?= " << len <<endl;
		bfs(i-1);
		cout << endl;
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值