hdu1021 Fibonacci Again 找规律 水题

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1021

 

Problem Description

There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).

Input

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).

Output

Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.

Sample Input

0

1

2

3 4

5

Sample Output

no

no

yes

no

no

no

 

手写 前10个数,你就会发现每隔4个数就会出现一个mod3的数,而且我们知道各个数位上的和能被3整除,那么就能被3整除这个基本规律,我们可以大胆的猜测n%4==2

#include<iostream>
#include<cstdio>
using namespace std;

int main(){
    int n;
    while(~scanf("%d",&n))
        if(n%4==2)
            printf("yes\n");
        else
            printf("no\n");

	return 0;
}

 

import java.util.Scanner;

public class hdu1021_Fibonacci_Again {

	public static void main(String[] args) {
		Scanner in = new Scanner(System.in);
		int n;
		while(in.hasNext()) {
			n = in.nextInt();
			if(n%4==2)
				System.out.println("yes");
			else
				System.out.println("no");
		}
	}

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值