05-树9 Huffman Codes (30分)

In 1953, David A. Huffman published his paper "A Method for the Construction of Minimum-Redundancy Codes", and hence printed his name in the history of computer science. As a professor who gives the final exam problem on Huffman codes, I am encountering a big problem: the Huffman codes are NOT unique. For example, given a string "aaaxuaxz", we can observe that the frequencies of the characters 'a', 'x', 'u' and 'z' are 4, 2, 1 and 1, respectively. We may either encode the symbols as {'a'=0, 'x'=10, 'u'=110, 'z'=111}, or in another way as {'a'=1, 'x'=01, 'u'=001, 'z'=000}, both compress the string into 14 bits. Another set of code can be given as {'a'=0, 'x'=11, 'u'=100, 'z'=101}, but {'a'=0, 'x'=01, 'u'=011, 'z'=001} is NOT correct since "aaaxuaxz" and "aazuaxax" can both be decoded from the code 00001011001001. The students are submitting all kinds of codes, and I need a computer program to help me determine which ones are correct and which ones are not.

Input Specification:

Each input file contains one test case. For each case, the first line gives an integer N (2≤N≤63), then followed by a line that contains all the N distinct characters and their frequencies in the following format:

c[1] f[1] c[2] f[2] ... c[N] f[N]

where c[i] is a character chosen from {'0' - '9', 'a' - 'z', 'A' - 'Z', '_'}, and f[i] is the frequency of c[i] and is an integer no more than 1000. The next line gives a positive integer M (≤1000), then followed by M student submissions. Each student submission consists of N lines, each in the format:

c[i] code[i]

where c[i] is the i-th character and code[i] is an non-empty string of no more than 63 '0's and '1's.

Output Specification:

For each test case, print in each line either "Yes" if the student's submission is correct, or "No" if not.

Note: The optimal solution is not necessarily generated by Huffman algorithm. Any prefix code with code length being optimal is considered correct.

Sample Input:

7
A 1 B 1 C 1 D 3 E 3 F 6 G 6
4
A 00000
B 00001
C 0001
D 001
E 01
F 10
G 11
A 01010
B 01011
C 0100
D 011
E 10
F 11
G 00
A 000
B 001
C 010
D 011
E 100
F 101
G 110
A 00000
B 00001
C 0001
D 001
E 00
F 10
G 11

Sample Output:

Yes
Yes
No
No

算法思路: 1、最优编码 —— 总长度(WPL)最小         2. 无歧义解码 —— 前缀码:数据仅存于叶子结点
3. 没有度为1的结点 —— 满足1、 2则必然有3                  注意:满足2、 3可不一定有1

这里首先判断wpl是否相同,接着判断是否存在前缀码,本算法采用简洁的处理方式,实际并没有建立哈夫曼树。

#include<bits/stdc++.h> 
using namespace std;

bool isPrefix(string& s1, string& s2) {
	int n1 = s1.size(), n2 = s2.size();
	int i = 0;
	while (i < n1 && i < n2 && s1[i] == s2[i]) i++;
	if (i == n1 || i == n2) return true;
	return false;
}

bool hasPrefix(vector<string>& st) {
	int n = st.size();
	for (int i = 0; i < n ; i++) {
		for (int j = i + 1; j < n; j++) {
			if (isPrefix(st[i], st[j])) return true;
		}
	}
	return false;
}

int main() {
	int N;
	cin >> N;
	char c;
	int f;
	priority_queue<int, vector<int>, greater<int>>pq;
	unordered_map<char, int> um;
	for (int i = 0; i < N; i++) {
		cin >> c >> f;
		pq.push(f);
		um[c] = f;
	}

	int wpl = 0;
	for (int i = 1; i < N; i++) { //N个数字,N-1次合并操作
		int t1 = pq.top();
		pq.pop();
		int t2 = pq.top();
		pq.pop();
		pq.push(t1 + t2);
		wpl += t1 + t2;
	}

	int cnt;
	cin >> cnt;
	vector<string> res;
	for (int k = 0; k < cnt; k++) {
		vector<char> ch(N);
		vector<string> st(N);
		int thisWpl = 0;
		for (int i = 0; i < N; i++) {
			cin >> ch[i] >> st[i];
			thisWpl += um[ch[i]] * st[i].size();
		}
		if (thisWpl == wpl && !hasPrefix(st)) res.push_back("Yes");
		else res.push_back("No");
	}
	for (auto x : res) cout << x << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值