Z城市居住着很多只跳蚤。在Z城市周六生活频道有一个娱乐节目。一只跳蚤将被请上一个高空钢丝的正中央。钢丝很长,可以看作是无限长。节目主持人会给该跳蚤发一张卡片。卡片上写有N+1个自然数。其中最后一个是M,而前N个数都不超过M,卡片上允许有相同的数字。跳蚤每次可以从卡片上任意选择一个自然数S,然后向左,或向右跳S个单位长度。而他最终的任务是跳到距离他左边一个单位长度的地方,并捡起位于那里的礼物。
比如当N=2,M=18时,持有卡片(10, 15, 18)的跳蚤,就可以完成任务:他可以先向左跳10个单位长度,然后再连向左跳3次,每次15个单位长度,最后再向右连跳3次,每次18个单位长度。而持有卡片(12, 15, 18)的跳蚤,则怎么也不可能跳到距他左边一个单位长度的地方。
当确定N和M后,显然一共有M^N张不同的卡片。现在的问题是,在这所有的卡片中,有多少张可以完成任务。Input
两个整数N和M(N <= 15 , M <= 100000000)。
Output
可以完成任务的卡片数。
Sample Input
2 4Sample Output
12Hint
这12张卡片分别是:
(1, 1, 4), (1, 2, 4), (1, 3, 4), (1, 4, 4), (2, 1, 4), (2, 3, 4),
(3, 1, 4), (3, 2, 4), (3, 3, 4), (3, 4, 4), (4, 1, 4), (4, 3, 4)
显然,对于满足要求的卡片(a1,a2,…….an,m),一定存在(x1,x2,……,xn,xn+1),使得为1
若上式成立,则gcd(a1,a2,……,an,m) = 1
所以我们只要找出不满足要求的卡片,即gcd(a1,a2,……,an,m) != 1的卡片即可
枚举m的因子,然后容斥一下就好了
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <map>
#include <vector>
#include <queue>
#include <set>
#define eps 1e-8
typedef long long ll;
const double PI = acos(-1.0);
const int maxn = 1e6;
const int INF = 1e9;
const ll linf = 0x3f3f3f3f3f3f3f3f;
using namespace std;
ll prime[maxn];
ll cnt;
ll n,m;
void div(ll x)
{
cnt = 0;
for(ll i = 2; i*i<=x; i++)
{
if(x%i == 0)
{
prime[cnt++] = i;
while(x%i == 0)
x /= i;
}
}
if(x != 1)
prime[cnt++] = x;
}
ll qsm(ll a, ll b)
{
ll base = a;
ll res = 1;
while(b)
{
if(b&1)
res *= base;
base *= base;
b >>= 1;
}
return res;
}
ll solve()
{
ll ans = 0;
div(m);
for(int i = 0; i<(1<<cnt); i++)
{
ll odd = 0;
ll pro = 1;
for(int j = 0; j<cnt; j++)
{
if(i & (1<<j))
{
odd++;
pro *= prime[j];
}
}
if(odd&1)
ans -= qsm(m/pro,n);
else
ans += qsm(m/pro,n);
}
return ans;
}
int main()
{
while(cin>>n>>m)
{
cout<<solve()<<endl;
}
return 0;
}