eclipse不支持tomcat8.0版本解决

如果你要使用tomcat8.0+版本的tomcat容器,但是你安装的eclipse不支持,最多只支持到apache tomcat v7.0怎么办,我的解决办法如下:

第一步:eclipse菜单help->eclipse marketplace 点击打开后界面如下:

第二步:在find搜索框中输入:Eclipse JST Server Adapters ,点go搜索 ,正常搜索第一条就是,如图:

第三步:点右下角的install安装,我这边已经安装过了,所以显示的是uninstall卸载  ,按照提示步骤,一步一步安装完,然后根据提示重启,会发现Apache Tomcat v8.0已经有了,就可以配置使用8.0+版本的tomcat了

 

 

注意:

 

在eclipse中安装tomcat8.5时,报错:

 

The Apache Tomcat installation at this directory is version 8.5.6.  A Tomcat 8.0 installation is expected.

解决办法: 
Windows中

 


 
  1. ①在Tomcat的安装目录中找到lib目录,再找到catalina.jar。使用压缩软件(WinRAR或是好压)打开它。

  2. ②依次找到并双击打开org\apache\catalina\util\ServerInfo.properties 文件


 
  1. server.info=Apache Tomcat/8.5.6

  2. server.number=8.5.6.0

  3. server.built=Oct 6 2016 20:15:31 UTC

改为:

 


 
  1. #Apache Tomcat/8.5.6

  2. server.info=Apache Tomcat/8.0.0

  3. #8.5.6.0

  4. server.number=8.0.0

  5. server.built=Oct 6 2016 20:15:31 UTC

在Linux中改法:

 


 
  1. cd [tomcat or tomee home(tomcat目录)]/lib

  2. mkdir catalina

  3. cd catalina/

  4. unzip ../catalina.jar

  5. vim org/apache/catalina/util/ServerInfo.properties

  6.  
  7. `把版本号改成如下形式:`

  8.  
  9. server.info=Apache Tomcat/8.0.0

  10. server.number=8.0.0

  11. server.built=May 11 2016 21:49:07 UTC

  12.  
  13. 接着把改好的ServerInfo.properties文件添加到catalina.jar中:

  14.  
  15. jar uf ../catalina.jar org/apache/catalina/util/ServerInfo.properties

  16. cd ..

  17. rm -rf catalina

Linux改法我没有实践,不过我是参照Linux的改法在Windows上操作的,所以应该不会错! 
其他版本要是也报这样的错,改法是一样的! 

阅读更多
上一篇在eclipse中安装tomcat8.0报错The Apache Tomcat installation at this directory is version 8.5.6A Tomcat 8.0
想对作者说点什么? 我来说一句

没有更多推荐了,返回首页

关闭
关闭
关闭