the kth great num(priority_queue优先队列)

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number. 

Output

The output consists of one integer representing the largest number of islands that all lie on one line. 

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

Hint

Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).
        
#include<iostream>
#include<cmath>
#include<string.h>
#include<cstdio>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
typedef long long ll;
int main(){
	int n,m;
	while(scanf("%d %d",&n,&m)!=EOF)
	{
		//默认数字大的优先级高,先出 
		//加上下面这句话greater 优先输出小数据 
		priority_queue<int,vector<int>,greater<int> >q;
		int a,b;
		char s[10];
		while(n--)
		{
			scanf("%s",s);
			if(s[0]=='I'){
			cin>>a;
			q.push(a);
			if(q.size()>m)q.pop(); 
			} 
			else if(s[0]=='Q'){
				b=q.top();
				printf("%d",b);
				printf("\n");
			}
		}
	}
} 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值